封面

内河船舶计算系统 2019

COMPASS Inland

用 户 手 册

iGeneral

中国船级社武汉规范研究所

二〇二〇年八月

目录

1. 软件介绍（Release Notes）

1.1. 软件概况

1.2. 版权信息

1.3. 使用环境

1.4. 坐标系统

1.5. 符号约定

1.6. 物理量单位约定

2. 基本操作（Basic Operations）

2.1. 主菜单

2.2. 工具栏

2.3. 主窗口(图形区域)

2.4. 对象面板、操作面板与属性面板

2.5. 命令窗口

2.6. 输出窗口

3. 操作向导(Modeling Guide)

3.1. 全局参数初始化

3.2. 构造几何模型

3.3. 构造船壳模型

3.4. 建立分析模型

3.5. 执行分析计算

3.6. 结果查看输出

3.7. 导入导出

4. 操作详解（Commands Reference）

4.1. 全局

4.2. 几何

4.3. 船壳

4.4. 编辑

4.5. 分析à船舶稳性

4.6. 分析à发证计算

4.7. 结果

5. 特殊船型建模

5.1. 艉封板

5.2. 首侧推孔

5.3. 带凸形甲板的油/化船

5.4. 双体船

6. 版本更新说明

6.1. V2019.20.0801

6.2. V2019.20.0601

6.3. V2019.20.0101

6.4. V6.19.1201

6.5. V6.19.1001

6.6. V6.19.0801

6.7. V6.19.0701

6.8. V5.18.0426

6.9. V5.18.0326

6.10. V5.18.0201

6.11. V5.18.0101

6.12. V5.17.1215

6.13. V5.17.1101

6.14. V5.17.1001

6.15. V5.17.0901

6.16. V5.17.0801

6.17. V5.17.0701

6.18. V5.17.0601

6.19. V5.17.0501

6.20. V5.17.0401

6.21. V5.17.0316

6.22. V5.17.0301

6.23. V5.17.0208

6.24. V5.17.0101

6.25. V5.16.1201

6.26. V5.16.1111

7. FAQ 常见问题及处理方法

Q1：打开以前创建的文件失败，怎么办？

Q2：构建模型所用时间比较长，如何可以提高效率？

Q3：生成网格曲面有“破洞”怎么办？

Q4：构造的曲面形状不好，怎么提高光顺性？

Q5：构造的网格曲面失败，怎么办？

Q6：采用“参数化舱室单元体”组合生成“舱室”时，不成功怎么办？

Q7：船体/舱室计算所得容积为负或随高度增加负增长？

Q8：曲面单元为何形状不光顺？


1. 软件介绍（Release Notes）

1. 软件介绍（Release Notes）

Copyrights 2019, 中国船级社武汉规范研究所. All rights reserved.


1.1. 软件概况

1.1. 软件概况

为船舶设计与审图发证提供可靠的计算手段。

（1）三维型表面与舱室建模，支持三维交互式建模，以及命令流快速建模。

（2）基于三维模型的静水力、舱容曲线、完整稳性、许用重心、破损稳性、倾斜试验计算，以及《内河船舶法定检验技术规则》2011、2015修改通报、2016修改通报、2018修改通报的校核衡准，和《特定航线江海直达船舶法定检验技术规则》2018的校核衡准。

（3）吨位计算，支持基于三维模型的容积计算，配套《内河船舶法定检验技术规则》2011、2015修改通报、2016修改通报、2018修改通报。

（4）EEDI计算，配套《内河绿色船舶规范》2018。


1.2. 版权信息

1.2. 版权信息

本软件系统由中国船级社武汉规范研究所研制开发，版权所有，非法翻版必究

我们欢迎用户反馈有益的建议和使用中遇到的问题

地址：武汉市硚口区六角亭新路128号

邮编：430022

电话：027-85423516（陈志飚） 85865132（陈庆任）

Email：zbchen@ccs.org.cn qrchen@ccs.org.cn


1.3. 使用环境

1.3. 使用环境

Windows 32/64位操作系统，建议使用WIN7的64位系统，物理内存8G以上。

需安装.netframework4.0


1.4. 坐标系统

1.4. 坐标系统

船体坐标系为直角正交坐标系

原点：尾垂线或船舯，用户可自定义，默认尾垂线

X轴：船长方向，指向船艏为正。

Y轴：船宽方向，指向左舷为正。

Z轴：型深方向，指向上方为正。

其中X坐标也支持肋位表达式和站位表达式，详见4.1.4


1.5. 符号约定

1.5. 符号约定

（1）不区分大小写

（2）对象名称首符号只能是英文字母，英文字母、数字、小数点、下划线、减号的组合

（3）建议的对象名称如下

站线 | S6：6号站线 S6_1：6号站线第一段 S0_2：0号站线第二段 | 水线 | WL1000_Aft：1000水线的尾段 WL2000_Bow：1000水线的首段 BL_Mid：基线中段
肋骨线 | F6：6号肋骨线 F6_1：6号肋骨线第一段 F0_2：0号肋骨线第二段 | 纵向线 | DeckLine_Aft：尾部甲板边线 Sheer_Mid：中部甲板中心线（脊弧线） CL_Bow：船底中纵剖线 Camber17：17号（站位/肋位）梁拱线
型表面 | Shell_Aft：尾部外板 Deck_Mid：中部甲板 | 舱室 | TankXXX：XXX液舱 RoomXXX：XXX舱


1.6. 物理量单位约定

1.6. 物理量单位约定

物理量 | 单位
长度 | m：主尺度（LBDd）、半波高r、各种间距、宽度、距离
 | mm：构件厚度、截面（剖面）尺寸
质量 | t：货物重量、车辆轴重、起吊重量等
时间 | s：一般
 | h：航程
 | min：试验
角度 | deg：横摇角、纵摇角等
温度 | ℃
速度 | m/s：航速、水流速度
 | km/h：航速
加速度 | m/s2
面积 | m2：甲板、舵等大件面积
 | cm2：构件截面
体积 | m3
剖面模数 (或静矩) | cm2·m：船体梁剖面
 | cm3：构件截面
惯性矩 | cm2·m2：船体梁剖面
 | cm4：构件截面
密度 | t/m3
积载因子 | m3/t
力 | kN
力矩 | kNm
压力 | Pa：风压、气压
 | MPa：气压
应力 | N/mm2：应力、屈服强度等
弹性模量 | GPa：钢材E=206
功率 | kW


2. 基本操作（Basic Operations）

2. 基本操作（Basic Operations）

本软件有七个主要区域：主菜单，工具栏，主窗口，对象面板，操作面板，命令窗口，输出窗口。


2.1. 主菜单

2.1. 主菜单

在主菜单区域中，主要文件、船舶、视图、工具、帮助、退出等操作菜单，下边依次介绍。


2.1.1. 文件

2.1.1. 文件

新建：创建新文件；

打开：打开已有的文件；

保存：保存当前的数据；

导入导出：导入型值表、IGS文件、DXF文件，导出IGS；

最近文件：记录最近打开的文件；

退出：退出本软件。


2.1.2. 船舶(工程信息

2.1.2. 船舶à工程信息

若不输出报告，可不必填写


2.1.3. 船舶(主要要素

2.1.3. 船舶à主要要素

其中LBD、Lpp和航区为必填项


2.1.4. 船舶(船体标尺

2.1.4. 船舶à船体标尺

设置完成后，点击菜单快捷栏 [image] ，可在窗口中显示图形标尺，如下：


2.2. 工具栏

2.2. 工具栏

在工具栏中，分为两个子区，一个是模块，一个是快捷工具。


2.2.1. 模块子区

2.2.1. 模块子区

Ø 几何 ：负责几何图元的设计，点、线、面和体；

Ø 船壳 ：负责船壳图元的设计，主船体、舱室单元体、舱室、附体等；

Ø 分析 ：负责分析计算模型的创建、计算，船舶稳性等；

Ø 结果 ：负责计算结果的读入、查看、输出，船舶稳性等。


2.2.2. 快捷工具(文件/

2.2.2. 快捷工具à文件

Ø 保存 [image] ：保存当前的模型数据。

Ø 撤销 [image] ：撤销当前的操作。

Ø 重做 [image] ：恢复撤销的操作。

Ø 帮助 [image] ：弹出帮助文档。


2.2.3. 快捷工具(显示/隐藏/

2.2.3. 快捷工具à显示/隐藏

Ø 点 [image] ：点显示的控制按键。

Ø 线 [image] ：线显示的控制按键。

Ø 面 [image] ：面显示的控制按键。

Ø 体 [image] ：体显示的控制按键。

Ø 主体：船壳模型显示的控制按键。

Ø 舱室：舱室模型显示的控制按键。

Ø 单元体：单元体模型显示的控制按键。

Ø 附体：附体模型显示的控制按键。

Ø 指定图元 [image] ：隐藏选中的图元（修改其Visible属性）

Ø 三角：高亮的体对象是否按三角网格模式显示，打开时按三角网格模式显示，用于体对象检查

Ø 肋位标尺 [image] ：肋位标尺显示的控制按键。


2.2.4. 快捷工具(常用//

2.2.4. 快捷工具à常用

Ø 联动：打开时，修改一条线对象或一个点对象，与之关联的线也会同时更新（耗时较多）

Ø 更新：点击后，更新选中的图元对象，一般用在“联动”未打开时对模型进行了修改后

Ø 删除当前图元 说明: DeleteHS ：选中图元，点击此按钮，即可删除图元。

Ø 镜像：将“操作面板”切换到“镜像”操作

Ø 修剪：将“操作面板”切换到“修剪”操作

Ø 求交：将“操作面板”切换到“求交”操作

Ø 复制：将“操作面板”切换到“复制”操作

Ø 创建：将“操作面板”切换到“创建”操作

Ø 视图自适应 说明: 自适应 ：使图形自适应图形区大小。

Ø 区域放大 说明: AlignToGridHS ：指定框选区域的放大。


2.2.5. 快捷工具(查找查询/

2.2.5. 快捷工具à查找查询

Ø 命令：查看当前图元的命令行。

Ø XYZ：查看当前曲线/点图元的节点坐标。

Ø #：查看当前曲线的肋位点坐标。

Ø $：查看当前曲线的站位点坐标。

Ø 查找图元 说明: 查找图元

Ø 查询坐标


2.2.6. 快捷工具(拾取捕捉/

2.2.6. 快捷工具à拾取捕捉

正常情况：支持点选、正向框选（全部落在框内被选中）、反向框选（被框住任意部分即选中）

Ø 筛选图元 [image] ：指定可拾取的图元类型。

Ø 关闭增量拾取 [image] ：取消当前所有选中的对象的选中状态。

Ø 捕捉曲线的首端节点 [image] ：打开捕捉曲线上的点，返回引用表达式“C/n=1”到“命令窗口”当前光标处或“操作面板”当前控件的光标处（C为曲线的名称）

Ø 捕捉曲线的尾端节点 [image] ：打开捕捉曲线上的点，返回引用表达式“C/n=-1”到“命令窗口”当前光标处或“操作面板”当前控件的光标处（C为曲线的名称）

Ø 捕捉曲线节点 [image] ：打开捕捉曲线上的点，返回引用表达式“C/n=?”到“命令窗口”当前光标处或“操作面板”当前控件的光标处（C为曲线的名称）

Ø 捕捉曲线上的点 [image] ：打开捕捉曲线上的点，返回引用表达式“C/X=?”或“C/Y=?”或“C/Z=?”到“命令窗口”当前光标处或“操作面板”当前控件的光标处（C为曲线的名称）

Ø 捕捉曲线的交点 [image] ：打开捕捉曲线的交点，返回引用表达式“C1/C2”到“命令窗口”当前光标处或“操作面板”当前控件的光标处（C1、C2为曲线的名称）


2.2.7. 快捷工具(特殊计算/

2.2.7. 快捷工具à特殊计算

Ø 查询浮性参数 [image] ：查询排水量、浮态等参数（需在静水力计算中指定主船体）。

吃水：可一次指定多个，逗号分隔

Ø 散货堆装计算 [image] ：按用户输入的参数，计算规则货仓的散货堆装参数


2.3. 主窗口(图形区域)

2.3. 主窗口(图形区域)

鼠标中键按住移动： 移动视图；

鼠标中间上下滚动： 缩放视图

鼠标右键按住移动： 旋转视图


2.4. 对象面板、操作面板与属性面板

2.4. 对象面板、操作面板与属性面板

对象面板显示已有模型的对象树，可更改对象名称、显示/隐藏对象图形显示、复制其名称（Ctrl+C）

操作面板可进行对象操作，如创建等

属性面板可直接修改已有对象的属性

模块 | 图元 | 操作
几何 | 点 | 创建/复制/镜像
 | 线 | 创建/复制/镜像/剪切/拼接
 | 面 | 创建/镜像/拼接/拆分/剪切/求交
 | 体 | 创建/镜像/剪切
船壳 | 主体 | 创建，主船体
 | 单元体 | 创建，参数化舱室单元体
 | 舱室 | 创建
 | 附体 | 创建
分析 | 船舶稳性 | 创建/计算
 | 发证计算 | 创建/计算
结果 | 船舶稳性 | 读入/输出，静水力、绑金曲线、舱容曲线、完整稳性、许用重心、破损稳性、倾斜试验
 | 发证计算 | 读入/输出，吨位计算、EEDI计算


2.5. 命令窗口

2.5. 命令窗口

输入对应操作的命令，然后用“ok”+回车键执行（也可以用鼠标中间点击或者Ctrl+回车）

!Cooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooomand::是命令提示

!开头的为注释行，不执行


2.6. 输出窗口

2.6. 输出窗口

输出命令执行结果


3. 操作向导(Modeling Guide)

3. 操作向导(Modeling Guide)

进行计算分析之前，首先要完成船壳建模，其一般顺序是：

（1）构造几何模型

型线（站线/肋骨线、梁拱线、甲板边线、纵剖线、脊弧线等）--> 船壳面（含外板和甲板，外板和甲板也可以不必要分开）

（2）构造船壳模型

船壳面（外表面、甲板面）-->主船体-->舱室

建模工作，可采用下述几种方式实现：

（1）面板操作：适用于初学者，或不经常使用本软件的用户

（2）命令操作：适用于熟练者，或系列船建模（主船体外观类似，尺度不同或局部不同）

（3）面板与命令混合操作：适用于精通者

以下将以一条双尾球艏的散货船为例一步一步进行介绍


3.1. 全局参数初始化

3.1. 全局参数初始化


3.1.1. 船舶/主要要素

3.1.1. 船舶/主要要素

通过菜单设置，其中Lpp和LBD必填

对应命令如下

MainPrinciple

Lpp 100

LBD 100,15.2,6

T 4.8

DSPL 4000

Cb 0.8

垂线间长m

规范船长、型宽、型深 m

吃水m

排水量t

方形系数

Lpp和LBD为必选关键字

其他为可选关键字


3.1.2. 船舶/船体标尺

3.1.2. 船舶/船体标尺

通过菜单设置，如需使用肋位坐标表达式和站位坐标表达式，则必须设置

对应命令如下：

HullCoord

Org -1

Fr0X 0

FrSpace (-6 205 0.500)

St0X 0

StNum 20

StAdd (-1 -5) (-0.5 -2.5) (0.5 2.5) (19.5 97.5) (20.5 102.5) (21 105)

原点类型，-1表示尾垂线，0表示船舯

0号肋位X坐标

肋位间距，第一行的“起始肋位”必须小于等于0

0号站位X坐标

等间距站数，按Lpp生成等站距站位表

附加站位（可选），插入站位表中


3.2. 构造几何模型

3.2. 构造几何模型

软件分为几大功能模块——几何、船壳、分析与结果，点击工具栏相应大图标按钮即可进入。

曲线：单向投影是最常用的型线构造方式，可生成站线/肋位线、水线、纵剖线等平面线

其次是XYZ，可生成甲板边线、折角线、尾封板外轮廓等空间线

曲面：网格线是最常用的曲面构造方式，线型复杂时建议采用此方法；

采用面板操作的单向投影方式生成曲线如下：

（1）双击“形状坐标”或单击后续的“.”按钮可弹出“坐标点编辑窗”

（2）点击“应用”执行

（3）执行完毕后在“命令窗口”会显示相应的命令

（4）执行完毕后在“输出窗口”会显示执行结果（成功及创建的图元名称、失败及失败原因）

小技巧：

（1）坐标点可采用引用表达式（见4.1.4）

（2）引用表达式可通过鼠标从图形窗口交互拾取或捕捉（见2.2.6快捷操作工具栏à拾取捕捉）得到。

（3）拾取与捕捉前，可通过树面板或快捷工具栏的 [image] 按钮隐藏掉不需要的图元

后续主要采用命令流方式介绍型线的构造，命令详情见第4章“操作详解”

命令流方式：

（1）在命令窗口中输入命令

（2）ok+回车执行（也可以ctrl+回车，或鼠标中键点击）

（3）命令、对象名不分大小写

（4）!（西文或中文感叹号）打头的行为注释行，不执行


3.2.1. 创建尾部型线

3.2.1. 创建尾部型线

!*******************************************

!***尾部横线

!6号站线(平行中体尾端线)

CURVE S6

X $6

YZ (0 0) (6.6 0) /0 90/ (7.6 1) (7.6 6.0)

!5号站线

CURVE S5

X $5

YZ (0 0) (6.333 0) /0 90/ (7.6 1) (7.6 6.0)

!4号站线

CURVE S4

X $4

YZ (0 0) (5.962 0) /0 (7.386 1) 90/ (7.6 2) (7.6 6.0)

!3号站线

CURVE S3

X $3

YZ (0 0) (5.392 0) /0 (6.79 1) (7.242 2) (7.475 3) 90/ (7.6 4) (7.6 6.0)

!2号站线

CURVE S2

X $2

YZ (0 0.581) (0.802 0.581) /0 (1.415 0.5) (2.104 0.25) (2.626 0) /0 (4.434 0) /0 (5.282 0.5) (5.742 1) (6.236 2) (6.682 3) (7.126 4) -/ (7.518 4.781) /- (7.518 6.83)

!1号站线

CURVE S1

X $1

YZ (0 2.464) (1.941 2.464) /0 (2.527 2) (2.651 1) (3.53 0.366) (4.404 1) (4.533 2) (4.947 3) /40 (6.289 4) (7.197 5) -/ (7.294 5.11) /- (7.294,6.897)

!0号站线

CURVE S0

X $0

YZ (0 3.799) (3.53 3.799) (3.832 3.799) /0 (5.193 4) (6.446 5) -/ (6.927 5.439) /- (6.927,6.963)

!尾封板外轮廓线

CURVE Aft_wfbline

XYZ (-2.4 0 4) (-2.4 4.468 4) /- (-2.567 5.95 5) (-2.668 6.66 5.608) /- (-2.9 6.66 7)

!*尾部折角线

CURVE Aft_AngleLine

XYZ S3/z=4.5 S2/n=-2 /- S1/n=-2 S0/n=-2 Aft_wfbline/n=-2

!***尾部甲板线

!*尾部下甲板线

CURVE Aft_DL

Z 6

XY S6 S5 S4 S3 S2 S1 S0 AFT_WFBLINE

!*尾部上甲板线

CURVE Aft_UD_Aut

XYZ (#28 7.6 6.771) S2/N=-1 S1/N=-1 S0/N=-1 AFT_WFBLINE/N=-1

!*尾部升高甲板线

CURVE Aft_DL_fz1

X Aft_UD_Aut/N=1

YZ Aft_AngleLine AFT_DL Aft_UD_Aut

!6号站梁拱

PARABOLA Camber6

DP S6/n=-1

BfY 15.2 0.4

!3号站梁拱

PARABOLA Camber3

DP S3/n=-1

BfY 15.2 0.4

!尾升高端面梁拱(#28)

PARABOLA Camber_DL_Aft

DP Aft_DL_fz1/n=-2

BfY 15.2 0.4

PARABOLA Camber_UDL_Aft

DP Aft_DL_fz1/n=-1

BfY 15.2 0.4

!尾封板梁拱

PARABOLA Camber_wfb

DP Aft_wfbLine/n=-1

BfY 15.2 0.4

!尾封板中横线

CURVE Aft_wfb_Z

Z Aft_wfbline/N=-2

XY Aft_wfbline/N=-2 (-2.668 0)

!尾封板竖线

CURVE Aft_wfb_Y

Y AFT_WFBLINE/N=2

XZ AFT_WFBLINE AFT_WFB_Z CAMBER_WFB

!*******************************************

!*尾部中纵剖线

CURVE Aft_CL

Y 0

XZ S6 S5 S4 S3 S2 S1 S0 Aft_wfbLine /- Aft_wfb_Z /- Camber_wfb

!*尾部甲板中心线

CURVE Aft_DCL

Y 0

XZ Camber6 Camber3 Camber_DL_Aft /- Camber_UDL_Aft /- Camber_wfb

!*******************************************

!***尾轴

!*尾轴端面

ELLIPSE Aft_Shaft_X

X 2.5

CENTER (3.53 1.35)

R 0.25

!*尾轴中间横剖线

ELLIPSE Aft_Shaft_X3

X 3

CENTER (3.53 1.35)

R 0.4

Angle 0 180

!*尾轴纵剖线

CURVE Aft_LL3530

Y 3.53

XZ Aft_wfbline (-1.8 3.99) S0 /352 Aft_Shaft_X3 Aft_Shaft_X

CURVE Aft_LL3530B

Y 3.53

XZ Aft_Shaft_X/Z<1.35 (3 0.95) S1 S2 /0 S3

CURVE Aft_Shaft_Z_A

Z 1.35

XY Aft_Shaft_X/Y<3.53 Aft_Shaft_X3/Y<3.53 S1/Y<3.53

CURVE Aft_Shaft_Z_B

Z 1.35

XY Aft_Shaft_X/Y>3.53 Aft_Shaft_X3/Y>3.53 S1/Y>3.53

CURVE Aft_Shaft_Aux1

XYZ S0/N=2 S1/N=8

CURVE Aft_Shaft_Aux2

XYZ S0/N=2 S1/N=2

CURVE Aft_Shaft_Aux3

Z Aft_LL3530/n=-2

XY Aft_LL3530/n=-2 S1/Y>3.53

CURVE Aft_Shaft_Aux4

Z Aft_LL3530/n=-2

XY Aft_Shaft_X3/Y=3.53 S1/Y<3.53

!*******************************************

!***其他辅助线，避免五边形面

!*尾封板辅助线

CURVE Aft_wfb_Aux

XYZ Aft_wfbline/n=2 S0/n=3

!*尾部基线

CURVE Aft_BL

Z 0

XY S6/n=2 s5/n=2 s4/n=2 s3/n=2 s2/n=6

!*******************************************

!***尾部型表面

SURF A_Aft

THR S6 S5 S4 S3 S2 S1 S0 Camber6 Camber3 Camber_DL_Aft Camber_UDL_Aft Aft_DL Aft_CL Aft_DCL Aft_AngleLine Aft_Shaft_X Aft_Shaft_X3 Aft_LL3530 Aft_LL3530B Aft_Shaft_Z_A Aft_Shaft_Z_B Aft_Shaft_Aux1 Aft_Shaft_Aux2 Aft_Shaft_Aux3 Aft_Shaft_Aux4 Aft_DL_fz1 Aft_BL Aft_wfbline Camber_wfb Aft_wfb_Z Aft_wfb_Y Aft_UD_Aut AFT_WFB_AUX


3.2.2. 创建首部型线

3.2.2. 创建首部型线

!*******************************************

!***首部横线

!17号站线(平行中体首端线)

CURVE S17

X $17

YZ (0 0) (6.6 0) /0 90/ (7.6 1) (7.6 6)

!18号站线

CURVE S18

X $18

YZ (0 0) (5.72 0) /0 (6.684 1) (7.02 2) (7.325 3) 90/ (7.6 4) (7.6 6)

!19号站线

CURVE S19

X $19

YZ (0 0) (2.406 0) /0 (3.963 1) (4.637 2) (5.204 3) (5.735 4) (6.289 5) (6.846 6) (7.179 7.42)

!19.5号站线

CURVE S19.5

X $19.5

YZ (0 0) (1.555 1) (1.911 2) (2.337 3) (3.196 4) (4.132 5) (5.105 6) (6.046 7.556)

!20号站线

CURVE S20_1

X $20

YZ (0 5.333) (1.244 6) (3.883 7.656)

CURVE S20_2

X $20

YZ (0 0.282) (0.1 0.31) (1.0 1) (1.143 2) (0.724 3) (0 3.377)

!* 首部甲板上边线

CURVE Bow_DL

XYZ (#184 7.6 7.19) S19/n=-1 S19.5/n=-1 S20_1/n=-1 ($20+2181 0 7.755)

!* 首部甲板下边线

CURVE Bow_WL_DL

Z S17/n=-1

XY S17 S18 (#184 7.6) /0 S19 S19.5 S20_1

!* 首部甲板升高边线

CURVE Bow_FR184

X Bow_DL/N=1

YZ Bow_WL_DL Bow_DL

!17号梁拱线

PARABOLA Camber17

DP S17/n=-1

BfY 15.2 0.4

!首升高梁拱线

PARABOLA Camber_DL_Bow

DP Bow_FR184/n=1

BfY 15.2 0.4

PARABOLA Camber_UDL_Bow

DP Bow_FR184/n=-1

BfY 15.2 0.4

!20号梁拱线

PARABOLA Camber_20

DP S20_1/N=-1

BfY 15.2 0.4

!*******************************************

!***首部纵线

!* 首部中纵剖线

CURVE Bow_CL

Y 0

XZ S17 S18 S19 S19.5 ($20-1095 0) /0 S20_2/Z<2 ($20+875 1) ($20+1259 2) ($20+898 3) S20_2/Z>2 ($20-628 4) ($20-266 5) S20_1/Z<6 ($20+622 6) ($20+1379 6.852) Bow_DL/n=-1

!* 首部甲板中心线

CURVE Bow_DCL

Y 0

XZ Camber17 Camber_DL_Bow /- Camber_UDL_Bow /- Camber_20 Bow_DL

!*******************************************

!***辅助线

!*20站分段点

CURVE Bow_WL_S20_1

Z S20_1/n=1

XY S20_1 S19.5 S19 s18 /180 s17

!*20站分段点（球艏）

CURVE Bow_WL_S20_2

Z S20_2/n=-1

XY S20_2 S19.5 S19 s18 /175 180/ s17

!*球艏高度中点

CURVE Bow_WL2000

Z 2

XY Bow_CL S20_2 S19.5 S19 s18 180/ s17

!*首部基线

CURVE Bow_BL

Z 0

XY S17/n=2 s18/n=2 s19/n=2

!*******************************************

!***首部型表面

SURF A_Bow

THR S17 S18 S19 S19.5 S20_1 S20_2 Camber17 Camber_DL_Bow Camber_UDL_Bow Bow_DL Bow_CL Bow_DCL Bow_WL_DL Bow_WL_S20_1 Bow_WL_S20_2 Bow_WL2000 Bow_BL Bow_FR184 Camber_20


3.2.3. 创建中部型线

3.2.3. 创建中部型线

!*******************************************

!***中部型表面

CURVE Mid_DL

XYZ S6/N=-1 S17/N=-1

CURVE Mid_BCL

Y 0

XZ S6,S17

CURVE Mid_DCL

Y 0

XZ Camber6 Camber17

!***底部基线

CURVE MID_y

Y S6/N=2

XZ S6 S17

!***平边线

CURVE MID_z

Y S6/N=3

XZ S6 S17

SURF A_Mid

THR Mid_DL Mid_DCL Mid_BCL S6 Camber6 S17 Camber17 MID_y MID_z


3.2.4. 整船表面的构造

3.2.4. 整船表面的构造

完成上述操作后，即完成了左舷部分的外表面和整个主甲板构造，右舷部分可通过镜像生成，如下：

在“操作”栏中，选择“镜像”；

在“对象”栏中，选择“任意类型图元”，系统默认；

在“源图元序列”栏中，输入所需镜像的曲面（或通过拾取）

最后，点击“应用”按钮，即可生成镜像面。

!其对应的命令行：

MIRROR

SOURCE A_Bow A_Aft A_Mid


3.3. 构造船壳模型

3.3. 构造船壳模型

工具栏中点击“船壳”，进入船壳模型构造

包括主船体、舱室、单元体、附体的构造。

这一步的总体思想是利用前面建立的几何面或几何体，来建立船壳图元。

其中构造舱室前要先建立主船体。

一般通过船壳的几何面生成主船体，下面以此为例示范。


3.3.1. 主船体的构造

3.3.1. 主船体的构造

采用面板操作如下

在“操作”栏中，选择“创建”；

在“对象”栏中，选择“主船体”；

在“方法”栏中，选择“来自面”；

在“型表面序列”栏中，输入面序列名称（或通过拾取）

最后，点击“应用”按钮，即可创建尾部外板几何面

!通过几何面直接构造主船体

HULL Hull_1

THR A_Bow A_Aft A_Mid A_Bow_M A_Aft_M A_Mid_M


3.3.2. 舱室的构造

3.3.2. 舱室的构造

从本质上看，舱室就是一个体。参看4.3.3。在构造舱室之前，须先构造主船体

舱室一般采用“参数化”方法构造

特殊形状的舱室，可以先构造几何体或体单元，然后通过几何体采用“来自体组合”的方法构造

体组合可以是“并”、“交”、“差”

注意：一般仅创建计算需要用到的舱室

!1号底舱

SPACE Bottom_1

X #28 #54

FPOINTS (5.62 1.5) (-5.62 Z-)

!1号左舷边舱

SPACE Wing_1_P

X #28 #54

FPOINTS (Y+ 5.62)

!1号右舷边舱

MIRROR Wing_1_S

SOURCE Wing_1_P

!2号底舱

SPACE Bottom_2

X #54 #80

FPOINTS (5.62 1.5) (-5.62 Z-)

!2号左舷边舱

SPACE Wing_2_P

X #54 #80

FPOINTS (Y+ 5.62)

!2号右舷边舱

MIRROR Wing_2_S

SOURCE Wing_2_P

!3号底舱

SPACE Bottom_3

X #80 #106

FPOINTS (5.62 1.5) (-5.62 Z-)

!3号左舷边舱

SPACE Wing_3_P

X #80 #106

FPOINTS (Y+ 5.62)

!3号右舷边舱

MIRROR Wing_3_S

SOURCE Wing_3_P

!4号底舱

SPACE Bottom_4

X #106 #132

FPOINTS (5.62 1.5) (-5.62 Z-)

!4号左舷边舱

SPACE Wing_4_P

X #106 #132

FPOINTS (Y+ 5.62)

!4号右舷边舱

MIRROR Wing_4_S

SOURCE Wing_4_P

!5号底舱

SPACE Bottom_5

X #132 #158

FPOINTS (5.62 1.5) (-5.62 Z-)

!5号左舷边舱

SPACE Wing_5_P

X #132 #158

FPOINTS (Y+ 5.62)

!5号右舷边舱

MIRROR Wing_5_S

SOURCE Wing_5_P

!6号底舱

SPACE Bottom_6

X #158 #184

FPOINTS (5.62 1.5) (-5.62 Z-)

!6号左舷边舱

SPACE Wing_6_P

X #158 #184

FPOINTS (Y+ 5.62)

!6号右舷边舱

MIRROR Wing_6_S

SOURCE Wing_6_P

!机舱

SPACE EngineRoom

X #12 #28

FPOINTS (5.62 Z-) (-5.62 Z+)

!机舱左舷边舱

SPACE EngineWing_P

X #12 #28

FPOINTS (Y+ 5.62)

!机舱右舷边舱

MIRROR EngineWing_S

SOURCE EngineWing_P

！轻油舱

SPACE FuelTankLight

X #9 #12

FPOINTS (-3.528 2.930) (3.528 Z+)

APOINTS (-3.528 3.452) (3.528 Z+)

！重油舱

SPACEUnit FuelTankHeavy_Unit1

X #0 #6

FPOINTS (-3.528 3.916) (3.528 5.8)

APOINTS (-3.528 4.549) (3.528 5.8)

SPACEUnit FuelTankHeavy_Unit2

X #4 #6

FPOINTS (-3.528 5.8) (3.528 Z+)

SPACE FuelTankHeavy

bool FuelTankHeavy_Unit1 +FuelTankHeavy_Unit2

！清水舱

SPACE WaterTankFresh

X X- #-3

FPOINTS (-3.528 Z-) (3.528 Z+)

！艏尖舱

SPACE Peak_Bow

X #184 X+


3.4. 建立分析模型

3.4. 建立分析模型

工具栏中点击“分析”大图标，建立分析模型，包括船舶稳性。

这一步的总体思想是建立与船壳模型相关的稳性分析模型。

其中分析模型中的“船舶à主要要素”直接引用全局船舶信息（通过“船舶”主菜单设定）。


3.4.1. 静水力

3.4.1. 静水力

通过操作面板“创建à船舶稳性”，在参数页勾选“静水力”创建

详见 4.5.1


3.4.2. 舱容

3.4.2. 舱容

通过操作面板“创建à船舶稳性”，在参数页勾选“舱容”创建

详见4.5.2


3.4.3. 完整稳性

3.4.3. 完整稳性

通过操作面板“创建à船舶稳性”，在参数页勾选“完整稳性”创建

详见4.5.3


3.4.4. 破损稳性

3.4.4. 破损稳性

通过操作面板“创建à船舶稳性”，在参数页勾选“破损稳性”创建

详见4.5.4


3.4.5. 许用重心高度

3.4.5. 许用重心高度

通过操作面板“创建à船舶稳性”，在参数页勾选“许用重心高度”创建

详见4.5.5


3.4.6. 倾斜试验

3.4.6. 倾斜试验

通过操作面板“创建à船舶稳性”，在参数页勾选“倾斜试验”创建

详见4.5.6


3.5. 执行分析计算

3.5. 执行分析计算

通过操作面板“计算à船舶稳性”，在参数页勾选“静水力”“舱容”……等计算项，执行分析计算

详见4.4


3.6. 结果查看输出

3.6. 结果查看输出

工具栏中点击“结果”大图标，读入并输出计算结果。

详见4.7


3.7. 导入导出

3.7. 导入导出

主菜单区域中点击“文件”，在其下拉菜单中点击“导入导出”，右边显示4个选项：导入型值表、导入IGS、导入DXF、导出IGS，4个选项的功能如下：

（1） 导入型值表：选择按照给定的Excel文件格式保存的型值表文件，并定义型值表中的站号信息后，导入软件并自动生成相应的横剖线、纵剖线、水线、梁拱线；具体操作详见3.7.1；

（2） 导入IGS：可导入三维建模保存的IGS文件，在软件中生成IGS文件保存的图元；具体操作详见3.7.2；

（3） 导入DXF：可导入CAD软件保存的DXF文件，在软件中生成文件保存的线；具体操作详见3.7.3；

（4） 导出IGS：可将建模完成的图元导出为IGS文件；具体操作详见3.7.4。

注：本软件的型值表导出是随静水力计算时完成导出。


3.7.1. 导入型值表

3.7.1. 导入型值表

（1） 型值表填写格式说明：

型值表分为半宽表和高度表，其格式要求如下：

1） 表格第一行是表格类型：半宽表或高度表。此行用于指示用户填写，程序不检查该行。

2） 表格第二行为型线名称。第一个单元格不计，命名规则为（所有字母不区分大小写）：

a） 水线：[position]WL，其中[position]为水线高度值，单位毫米，如1000WL。

b） 纵剖线：[position]BL，其中[position]为纵剖线宽度值，单位毫米，如2000BL。中纵剖线：CenterLine或0BL，平边线：FlatSide。

c） 空间线：用户自定义名称，但需保证半宽表和高度表一致，如DeckSideLine，Deck，Jbbx等。

d) 折角线：折角线名称以ZJ开头，并保证半宽表和高度表一致，如有多条折角线，可用不同编号区别，如ZJ1、ZJ2、ZJ3等。

3） 表格第一列为站号。从第三行开始，按站号输入即可。站号可以为整数或实数ST，如1,1.5等，亦可以ST±offset，如1+100，其中offset为以毫米为单位的正整形或实型数，表示ST站向前/后偏移offset的纵向位置。高度表和半宽表的站号列必须一致。

4）表格中部为型值数据。允许以米或毫米为单位，空型值一律以符号’-’表示；允许一个单元格中填写多个数值，各个数值间以 / 隔开，并按从小到大的顺序填写，如1240/2056/3470。

（2） 安装文件夹下Data文件夹中的“型值表导入算例-105m货船型值表.xls”，可做参考；

（3） 在“船舶”——“船体标尺”中，定义型值表中站号“Station”对应的坐标值；

（4） 点击“导入型值表”，选择需要导入的Excel文件，点击确定后，弹出如下图弹框，

显示导入控制点：勾选后会创建型值表中的数据点，一般不需要勾选；

创建水线：勾选后会根据型值表创建水线，不勾选则不创建；

梁拱：填写梁拱值，用于创建梁拱线，未填则默认梁拱值为0

注：第二步的站号信息如未定义，会默认所有横剖线的x值为0，导致建模错误。


3.7.2. 导入IGS

3.7.2. 导入IGS

（1） 点击“导入IGS”，选择需要导入的IGS文件，单击“打开”按钮，此时弹出“导入IGES”对话框，选择导入选项后，然后点击“确定”按钮，开始导入IGES文件；

（2） “缩放”：可对IGS的图元尺寸进行缩放；稳性计算软件的几何模型的尺度单位是m，如果IGS存储的图元尺度单位是其他单位，则可通过缩放进行转换；

（3） “坐标系变换”：可对IGS的图元进行坐标系变换；

（4） “导入模式”有两种，其中“新建”表示将新建一个新的csx文件，再导入IGS文件中的图元；

“合并”表示将IGS文件中的图元直接导入当前打开的csx文件。


3.7.3. 导入DXF

3.7.3. 导入DXF

（1） 将需要导入的CAD文件转存为dxf文件；导入时会将dxf保存的所有线条（包括图形边界线）都导入，为了方便导入后的建模，需要删除dxf中建模不需要的线条，只保留建模需要的型线，主要为横剖线；

（2） 点击“导入DXF”，在弹出的文件选择对话框中选择待导入的DXF文件；点击确定，将DXF文件中的二维型线导入到软件中；

（3） 将二维CAD型线转换为三维型线：首先单击右键，选择“交点设为坐标原点”设定二维型线的坐标原点；

（4） 输入旋转平移转换参数，将二维型线转换为3维型线。


3.7.4. 导出IGS

3.7.4. 导出IGS

导出IGS有两种导出方式，一种是导出建模的所有图元，一种是导出建模图元中的某一些图元。

（1） 点击“导出IGS”，在弹出的文件框中填写导出IGS保存的文件名，单击“保存”按钮，此时弹出“导出IGES”对话框，选择导出选项后，然后点击“确定”按钮，开始导出IGES文件；

（2） 在“导出选中”的选项选择“选中”或“未选中”时，需要先选择图元后再点击“导出IGS”。


4. 操作详解（Commands Reference）

4. 操作详解（Commands Reference）


4.1. 全局

4.1. 全局

本软件提供的建模功能一般都可通过在命令窗口输入命令，或通过操作面板执行。


4.1.1. 命令执行

4.1.1. 命令执行

三种方式：

（1）命令之后换行输入“ok”回车：执行到光标所在位置

（2）命令之后ctrl+回车：执行到光标所在位置

（3）命令窗口，鼠标中键点击：执行到窗口末尾

命令关键字和对象名称不区分大小写

命令参数之间分隔符可采用空格或逗号

!（西文感叹号）打头的行为注释行，不执行


4.1.2. 主要要素

4.1.2. 主要要素

可通过菜单设置，详见2.1.3，也可通过命令实现，如下

MainPrinciple

Lpp 100

LBD 100,15.2,6

T 4.8

DSPL 4000

Cb 0.8

垂线间长m

规范船长、型宽、型深 m

吃水m

排水量t

方形系数

Lpp和LBD为必选关键字

其他为可选关键字


4.1.3. 船体标尺

4.1.3. 船体标尺

可通过菜单设置，详见2.1.4，也可通过命令实现，如下

HullCoord

Org -1

Fr0X 0

FrSpace (-6 220 0.500)

St0X 0

StNum 20

StAdd (0.5 2.5) (19.5 97.5)

原点类型，-1表示尾垂线，0表示船舯

0号肋位X坐标

肋位间距，第一行的“起始肋位”必须小于等于0

0号站位X坐标

等间距站数，按Lpp生成等站距站位表

附加站位（可选），插入站位表中


4.1.4. 坐标表达式

4.1.4. 坐标表达式

（1）站位表达式：用于X坐标分量

$10 表示10号站位，使用之前要设置船体标尺/站位表（参看_Ref447093593）

$10+200 表示10号站位+200mm

（2）肋位表达式：用于X坐标分量

#46 表示46号肋位，使用之前要设置船体标尺/肋距表（参看_Ref447093612）

#46-200 表示46号肋位-200mm

（3）引用表达式：用于一维坐标（X/Y/Z）或平面坐标（XY/YZ/XZ）或空间坐标（XYZ），程序自动根据需要取该点相应的坐标分量

C1 | 用于平面坐标，表示C1曲线与该平面的交点
C1/Z=3 | 用于任意坐标，表示C1曲线与Z=3平面的交点
C1/Y>3 | 用于平面坐标，表示C1曲线与该平面的多个交点中Y>3的交点 也可以用Y<3，或Y~3（表示约等于3）
C1/C2 | 用于任意坐标，表示C1曲线与C2曲线的交点
C1/n=？ | 用于任意坐标，表示C1曲线上的第？个节点
C1/n=-？ | 用于任意坐标，表示C1曲线上的倒数第？个节点


4.2. 几何

4.2. 几何

工具栏点击“几何”大图标，进入几何模块。


4.2.1. 点命令

4.2.1. 点命令

点的操作是几何模型处理中最基本的，它包括创建和修改（通过属性面板）

命令 | 注释 | 对应操作面板
POINT name LOC (x,y,z) | name是自定义的名字。（x,y,z）为三维点的坐标。 |
例：POINT P1 LOC (100,100,200) |
更高级的方法: POINT name LOC C1/X=10 POINT name LOC C1/C2 | C1，C2是曲线的名字 C1/X=10代表X=10平面与曲线相交的点。 C1/C2代表两曲线C1和C2的交点。


4.2.2. 线命令

4.2.2. 线命令

用户可它包括创建和修改（通过属性面板）。

线的创建方式有以下五种： XYZ，单向投影，双向投影，椭圆弧，抛物线等，以下分别介绍：


4.2.2.1. XYZ方式

4.2.2.1. XYZ方式

命令 | 注释 | 对应操作面板
CURVE name XYZ p1 p2 p3 … [POLY] | name新曲线的名字 p1可以是点的名字，或者坐标(x1,y1,z1) 或者两条曲线的交点，c1/c2 或者曲线上的指定点 c1/Z=3：曲线c1上Z=3的点 c1/X=3：曲线c1上X=3的点 POLY可选，有它表示生成折线 |
例： CURVE C1 XYZ (-157,-183,-26),(-69,-17,51) | 通过坐标点相连构造的曲线(B样条)
更高级的用法： p1 p2 /- p3 p4 | p2位置处为折角点


4.2.2.2. 单向投影：也可叫平面曲线（某个平面上的曲线）

4.2.2.2. 单向投影：也可叫平面曲线（某个平面上的曲线）

命令 | 注释 | 对应操作面板
CURVE name X x0 YZ p1 p2 p3 例子： CURVE STERN2 X 0.77 YZ FW30/Y>2 (0,8) | x0可以是数值，肋位坐标，站位坐标，或曲线上指定点（内部处理时取相应分量作为输入） p1 可以是坐标(y1 z1)，或曲线上的点 曲线上点的表达方式： C1/C2：C1与C2交点 C1：C1与x0平面交点 C1/Y<3：C1与x0平面的多个交点中 Y<3的交点 C1/Y>3：C1与x0平面的多个交点中 Y>3的交点 C1/Y=3：C1与x0平面的多个交点中 Y=3的交点 C1/Y=#3：C1与x0平面的多个交点中 Y≈3的交点 |
更高级的用法： 例： Curve SS Z 0 XY A,/45,0/,B,/60,C,D,/-,E | 创建曲线SS， A点：45度切出 B点：0度切入，60度切出 D点：折角点
示意图 节点先后顺序即为曲线方向 |


4.2.2.3. 双向投影

4.2.2.3. 双向投影

命令 | 注释 | 对应操作面板
CURVE name XY (x11,z11) (x21,y21) … YZ (y1,z1) (y2,z2) … | 通过两形状面相交而得到的曲线 (x11 y11)对应在XY平面的投影坐标 (y1,z1) 对应在YZ平面的投影坐标 |
例： CURVE C3 XZ (0 0) (-2 4) YZ (0 0) (7 0) /0 (8 1) /90 (8 4) | 创建斜面艉封板轮廓线

注：第1投影面为辅投影面，用于确定双向投影线所在的面；

第2投影面为主投影面，用于确定双向投影线的节点。

艉封板轮廓线、双尾的轴脊轮廓线，一般可用双向投影线创建


4.2.2.4. 椭圆弧

4.2.2.4. 椭圆弧

命令 | 注释 | 对应操作面板
半径方式： ELLIPSE name X x0 CENTER (y,z) R r1 r2 ANGLE a,b | x0是X轴上的坐标，可采用引用表达式 (y,z)是圆心坐标 r1r2是圆弧y轴和Z轴半径 [a,b] 角度区间，如果a>b则表示反向 |
梁拱方式： ELLIPSE name DP (x,y,z) BfY B f [Yc] [FULL] | (x,y,z)是甲板边点（可采用引用表达）. B 梁拱参考宽度，可正可负，负数与图相反 f 梁拱参考高度，可正可负，负数表示下凹 Yc 甲板中心Y坐标，可选，缺省表示0 FULL表示全甲板梁拱 f=0时退化为直线 |
三点方式： ELLIPSE name X x0 LOC (y1,z1) (y2,z2) (y3,z3) | x0是X轴上的坐标，可采用引用表达 (y1,z1) (y2,z2) (y3,z3)是圆弧三点（可引用表达） |


4.2.2.5. 抛物线

4.2.2.5. 抛物线

命令 | 注释 | 对应操作面板
梁拱方式： PARABOLA name DP (x,y,z) BfY B f [Yc] [FULL] | (x,y,z)是甲板边点（可采用引用表达）. B 梁拱参考宽度，可正可负，负数与图相反 f 梁拱参考高度，可正可负，负数表示下凹 Yc 甲板中心Y坐标，可选，缺省表示0 FULL表示全甲板梁拱 f=0时退化为直线 |
三点方式： PARABOLA name X x0 LOC (y1,z1) (y2,z2) (y3,z3) | x0是X轴上的坐标，可采用引用表达 (y1,z1) (y2,z2) (y3,z3)是圆弧三点（可引用表达） |


4.2.3. 面命令

4.2.3. 面命令

可创建和修改曲面，提供扫掠、拉伸、旋转等功能生成特殊面。

面的创建方式有：网格线，单向放样，扫掠，旋转，管道，球面。


4.2.3.1. 网格线

4.2.3.1. 网格线

命令 | 注释 | 对应操作面板
SURF name THR c1,c2, … | c1，c2是构成网格面的线序列。 注：输入的线序列能够围成闭合的区域。 |
例： SURF S1 THR C1,C2,C3,C4 | 由C1，C2，C3，C4构成生成的曲面S1.
更高级的用法： SURF THR all | 用所有已创建的曲线生成曲面


4.2.3.2. 单向放样

4.2.3.2. 单向放样

命令 | 注释 | 对应操作面板
LOFT name THR c1, c2 … | 通过一系列的曲线（如站线）放样来得到曲面。 c1,c2是系列曲线的名称 |
例： LOFT A1 THR C12,C10 | 生成面A1，放样线为C12,C10.


4.2.3.3. 扫掠

4.2.3.3. 扫掠

命令 | 注释 | 对应操作面板
SWEEPSURF name BASE c1 GENERATE c2 | 通过基线沿引导线方向扫描得到曲面。 c1是基线, c2是引导线。 注：生成甲板等，常用此方法。 |
例： SWEEPSURF A1 BASE C1 GENERATE C2 | 采用扫掠方法生成A1面，基线是C1，引导线是C2


4.2.3.4. 球面

4.2.3.4. 球面

命令 | 注释 | 对应操作面板
SPHERESURF name CENTER (x,y,z) (x1 y1 z1) RH r h | (x,y,z) 是球冠的底面中心C坐标 (x1,y1,z1)是C与球心连线之间的点C1 r是球冠底面半径，r≥0 h是球冠高度，h>0 h=r表示半球 r=0表示球，此时h表示球直径，C1可省略 |
例： SPHERESURF A1 CENTER (50,61,11) RH 0 200 | 生成以(50,61,11)为圆心，半径为100的圆。


4.2.3.5. 旋转

4.2.3.5. 旋转

命令 | 注释 | 对应操作面板
ROTATIONSURF name AXIS (x1,y1,z1),(x2,y2,z2) BASE c1 ANGLE a | (x1,y1,z1),(x2,y2,z2)是旋转轴端点坐标， c1是基线 a是旋转角度。 |
例： ROTATIONSURF S1 AXIS (-375,-179,-75) (-132,-72,-257) BASE C1 ANGLE 200 | 通过旋转生成面S1 旋转轴是以端点(-375,-179,-75) (-132,-72,-257)相连的直线 基线是C1 旋转角度是200

注：如果生成的面旋转方向不对，可以将旋转轴端点顺序调换下


4.2.3.6. 管道面

4.2.3.6. 管道面

命令 | 注释 | 对应操作面板
PIPE name GENERATE c1 R r | 以基线c1为轴心半径r的水管面 c1是基线名称 r是管道面的半径。 |
例： PIPE A1 GENERATE C1 R 100 | 以基线C1,半径100，创建管道面A1。


4.2.4. 体命令

4.2.4. 体命令

体创建的方式有：长方体、球体、围拢，扫掠，旋转，球体。


4.2.4.1. 围拢

4.2.4.1. 围拢

命令 | 注释 | 对应操作面板
SOLID name THR A1,A2,….. | A1，A2…是构成体的源面名称。 注：输入的面序列能够围城封闭的体。 |
例： SOLID SLD1 THR S1,SD,Y7621,FR6,FR30 | 以围拢的方式构造一个体，其围拢的面为S1,SD,Y7621,FR6,FR30


4.2.4.2. 体组合（几何体）

4.2.4.2. 体组合（几何体）

命令 | 注释 | 对应操作面板
SOLID name BOOL B1 B2 … | 通过几何体B1、B2布尔运算组合成几何体 支持+（并）-（差）*（交），运算符与图元名称之间不能有空格 |
例： SOLID SLD1 BOOL B1 +B2 -B3 *B4 | 通过体B1与B2求并，然后与B3求差，最后与B4求交得到几何体sld1


4.2.4.3. 长方体

4.2.4.3. 长方体

命令 | 注释 | 对应操作面板
Box Name CENTER (x,y,z) LBH a b c | (x y z)长方体中心 abc长方体长宽高 |
例： Box B1 CENTER (0 0 0) LBH 3 2 1 | 创建以（0 0 0）为中心，长3宽2高1的长方体


4.2.4.4. 球体

4.2.4.4. 球体

命令 | 注释 | 对应操作面板
SPHERESOLID name CENTER (x,y,z) (x1 y1 z1) RH r h | (x,y,z) 是球冠的底面中心C坐标 (x1,y1,z1)是C与球心连线之间的点C1 r是球冠底面半径，r≥0 h是球冠高度，h>0 h=r表示半球 r=0表示球，此时h表示球直径，C1可省略 |
例： SPHERESOLID B1 CENTER (50,61,11) RH 0 200 | 生成以(50,61,11)为圆心，半径为100的球。


4.2.4.5. 圆柱

4.2.4.5. 圆柱

命令 | 注释 | 对应操作面板
CYLINDERSOLID name CENTER (x1,y1,z1) (x2 y2 z2) R r1 r2 | (x1,y1,z1) (x2,y2,z2)是圆柱底面中心 r1r2是圆柱底面半径，r≥0 |
例： CYLINDERSOLID CENTER (0 0 0) (2 0 0) R 0.5 0.5 | 生成以(0,0,0) (2,0,0)为圆心，半径为0.5的圆柱。


4.2.4.6. 圆罐体

4.2.4.6. 圆罐体

命令 | 注释 | 对应操作面板
RTANKSOLID name CENTER (x1,y1,z1) (x2 y2 z2) RH (r1 h1) (r2 h2) | (x1,y1,z1) (x2,y2,z2)是圆柱底面中心 r1r2是圆柱底面半径，r≥0 h1h2是球冠高度，h>0 |
例： RTANKSOLID CENTER (3 0 0) (6 0 0) RH (0.5 0.5) (0.5 0.5) | 生成以(3 0 0) (6 0 0)为圆柱底面圆心，半径为0.5球冠高度为0.5的圆罐。


4.2.4.7. 扫掠

4.2.4.7. 扫掠

命令 | 注释 | 对应操作面板
SWEEPSOLID name BASE A1 GENERATE c2 | 通过基线沿引导线方向扫描得到曲面。 A1是基面, c2是引导线。 |
例： SWEEPSOLID B1 BASE A1 GENERATE C2 | 采用扫掠方法生成B1体 基面是A1，引导线是C2


4.2.4.8. 旋转

4.2.4.8. 旋转

命令 | 注释 | 对应操作面板
ROTATIONSOLID name AXIS (x1,y1,z1),(x2,y2,z2) BASE A1 ANGLE a | (x1,y1,z1),(x2,y2,z2)是旋转轴的端点坐标 A1是基面， a旋转的角度，单位是度。 |
例： ROTATIONSOLID SLD1 AXIS (-127,6935,49.9924,9.429), (-274.9335,-68.7059,-139.5) BASE S1 ANGLE 200 | 构造生成旋转体SLD1， 以(-127,6935, 49.9924, 9.429) (-274.9335, -68.7059, -139.5)连接成的直线为旋转轴 基线是S1 旋转角度是200度。


4.3. 船壳

4.3. 船壳

工具栏点击“船壳”大图标，进入船壳模块。


4.3.1. 主船体

4.3.1. 主船体


4.3.1.1. 来自面（几何面或船壳面围体）

4.3.1.1. 来自面（几何面或船壳面围体）

命令 | 注释 | 对应操作面板
HULL HULL_1 THR A1 A2 … | HULL_1是缺省和默认名称，其中1是序号，也可指定为2（表示第2个主船体，适用于双体船） 通过A1、A2面围成主船体 A1、A2可以是几何面、甲板面、外板面 |
例： HULL THR A1 A2 | A1、A2面围成主船体HULL_1


4.3.1.2. 来自体组合（几何体、主船体、附体、单元体、舱室）

4.3.1.2. 来自体组合（几何体、主船体、附体、单元体、舱室）

命令 | 注释 | 对应操作面板
HULL BOOL B1 B2 … | HULL_1是缺省和默认名称，其中1是序号，也可指定为2（表示第2个主船体，适用于双体船） 通过几何体B1、B2布尔运算组合成主船体 支持+（并）-（差）*（交），运算符与图元名称之间不能有空格 |
例： HULL BOOL B1 +B2 -B3 *B4 | 通过体B1与B2求并，然后与B3求差，最后与B4求交得到主船体HULL_1


4.3.2. 单元体

4.3.2. 单元体

单元体目前仅用于构造舱室


4.3.2.1. 体组合（几何体、主船体、附体、单元体、舱室）

4.3.2.1. 体组合（几何体、主船体、附体、单元体、舱室）

命令 | 注释 | 对应操作面板
SPACEUNIT name BOOL B1 B2 … | 通过体B1、B2布尔运算组合成单元体 支持+（并）-（差）*（交），运算符与图元名称之间不能有空格 |
例： SPACEUNIT SLD1 BOOL B1 +B2 -B3 *B4 | 通过体B1与B2求并，然后与B3求差，最后与B4求交得到单元体sld1


4.3.2.2. 参数化（艏艉端面轮廓特征点）

4.3.2.2. 参数化（艏艉端面轮廓特征点）

命令 | 注释 | 对应操作面板
SPACEUnit Name X [x1,x2] APOINTS pa1 pa2 … FPOINTS pf1 pf2 … [FROM HULL_1] | x1 x2是舱室的尾端和首端x坐标 pa1 pa2是尾端面轮廓特征点，缺省表示与首端面相同，否则其特征点个数应与首端面相同 pf1 pf2是首端面轮廓特征点，缺省表示整个剖面 APOINTS与FPOINTS可以只出现一个，此时表示与另一个端面轮廓特征点相同 FROM Hull_1为默认缺省，表示1号主船体上的舱室 FROM Hull_2不能缺省，表示2号主船体上的舱室，适用于双体船等 |
例： SPACEUNIT X [3,5] APOINTS | 在HULL_1上创建端面位置[3 5]的参数化舱室单元体 尾端面轮廓为整个船体 首端面轮廓为整个船体
高级用法：（特殊坐标分量） X+ X- Y+ Y- Z+ Z- | X+表示船首，X-表示船尾 Y+表示左舷，Y-表示右舷 Z+表示甲板，Z-表示船底 | Y-可用右舷以外的某个Y值替代 其他类似

端面特征点的用法同舱室，见4.3.3.2、4.3.3.3、4.3.3.4、4.3.3.5、4.3.3.6。


4.3.3. 舱室

4.3.3. 舱室


4.3.3.1. 来自体（几何体、主船体、附体、单元体、舱室）

4.3.3.1. 来自体（几何体、主船体、附体、单元体、舱室）

命令 | 注释 | 对应操作面板
SPACE Name THR SO1 -SO2 *SO3 … | SO1、SO2、SO3体布尔组合构成舱室 + - * 表示体之间的并、差、交 布尔运算，运算符与图元名称之间不能有空格 |
例： SPACE THR B1 +B2 -B3 | 表示B1与B2求并，然后与B3求差，得到舱室体


4.3.3.2. 参数化（艏艉端面轮廓特征点）

4.3.3.2. 参数化（艏艉端面轮廓特征点）

命令 | 注释 | 对应操作面板
SPACE Name X [x1,x2] APOINTS pa1 pa2 … FPOINTS pf1 pf2 … [FROM HULL_1] | x1 x2是舱室的尾端和首端x坐标 pa1 pa2是尾端面轮廓特征点，缺省表示与首端面相同，否则其特征点个数应与首端面相同 pf1 pf2是首端面轮廓特征点，缺省表示整个剖面 APOINTS与FPOINTS可以只出现一个，此时表示与另一个端面轮廓特征点相同 FROM Hull_1为默认缺省，表示1号主船体上的舱室 FROM Hull_2不能缺省，表示2号主船体上的舱室，适用于双体船等 |
例： SPACEUNIT X [3,5] APOINTS | 在HULL_1上创建端面位置[3 5]的舱室 舱室尾端面为整个船体 舱室首端面为整个船体
高级用法：（特殊坐标分量） X+ X- Y+ Y- Z+ Z- | X+表示船首，X-表示船尾 Y+表示左舷，Y-表示右舷 Z+表示甲板，Z-表示船底 | Y-可用右舷以外的某个Y值替代 其他类似


4.3.3.3. 端面轮廓特征点（0个）

4.3.3.3. 端面轮廓特征点（0个）

表示整个主船体剖面

SPACE

X [3,5]

APOINTS

在HULL_1上创建端面位置[3 5]的舱室

舱室尾端面为整个船体

舱室首端面为整个船体


4.3.3.4. 端面轮廓特征点（1个）

4.3.3.4. 端面轮廓特征点（1个）

(Z-,Z1) 例如： (Z-,0.8) | 表示Z1平面以下部分 表示0.8m以下的部分，通常用于生成双层底舱
(Z+,Z1) 例如： (Z+,0.8) | 表示Z1平面以上部分 表示0.8m以上的部分
(Y-,Y1) 例如： (Y-,-4) | 表示Y1平面以右部分 表示右舷距中纵剖面4m以外的部分，通常用于生成右边舱
(Y+,Y1) 例如： (Y+,4) | 表示Y1平面以左部分 表示左舷距中纵剖面4m以外的部分，通常用于生成左边舱


4.3.3.5. 端面轮廓特征点（2个）

4.3.3.5. 端面轮廓特征点（2个）

表示两个特征点对角线的矩形区域

(Y1,Z1),(Y2,Z2) 或 (Y1,Z2),(Y2,Z1) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y2,Z-) 或 (Y2,Z1),(Y1,Z-) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y2,Z+) 或 (Y2,Z1),(Y1,Z+) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y-,Z2) 或 (Y1,Z2),(Y-,Z1) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y+,Z2) 或 (Y1,Z2),(Y+,Z1) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y-,Z-) 或 (Y1,Z-),(Y-,Z1) | 表示两个特征点对角线的矩形
(Y1,Z1),(Y+,Z+) 或 (Y1,Z+),(Y+,Z1) | 表示两个特征点对角线的矩形


4.3.3.6. 端面轮廓特征点（＞2个）

4.3.3.6. 端面轮廓特征点（＞2个）

表示端面形状以特征点按顺时针方向（空间坐标系中是右手方向）顺序连接（尾与首连接）所形成的封闭区域。

特殊坐标点：（P+，θ)或（P-，θ)，表示倾斜舱壁(非水平舱壁和非垂直舱壁)与船壳的交点

P-表示以该坐标点的上一点为极点，按角度θ射线与船壳相交的交点，若没有上一个点则取尾点；

P+表示以该坐标点的下一点为极点，按角度θ射线与船壳相交的交点，若没有下一个点则取首点；

θ表示射线在端面内与Y轴的夹角（度，顺时针），取值范围[0,360)

(Y1,Z1),(Y-,Z1),(Y1,Z+) | Y1,Z1为1号点坐标
(Y1,Z1), (Y2,Z2),(Y2,Z-),(Y1,Z+) | Y1,Z1为1号点坐标 Y2,Z2为2号点坐标
(Y1,Z1), (Y2,Z2),(Y2,Z+),(Y1,Z-) | Y1,Z1为1号点坐标 Y2,Z2为2号点坐标
(Y1,Z1),(Y2,Z2),(Y3,Z3),(Y-,Z4),(Y5,Z-) | Y1,Z1为1号点坐标
(Y1,Z1),(Y2,Z-),(Y-,Z3),(Y4,Z4)(Y5,Z5) | Y1,Z1为1号点坐标
(Y1,Z1),(P-,75),(P+,225) | Y1,Z1为1号点坐标，图示Y1为负 P+ P-为特殊标记 75°为1号点与2号点连线的方向角 225°为1号点与3号点连线的方向角
(Y1,Z1),(P-,225),(P+,75) | Y1,Z1为1号点坐标，图示Y1为负 225°为1号点与2号点连线的方向角 75°为1号点与3号点连线的方向角
(Y1,Z1),(P-,225),(P+,315),(Y4,Z4) | Y1,Z1为1号点坐标，图示Y1为负 225°为1号点与2号点连线的方向角 315°为4号点与3号点连线的方向角
(Y1,Z1),(Y2,Z2),(P-,315),(P+,225) | Y1,Z1为1号点坐标，图示Y1为负 315°为2号点与3号点连线的方向角 225°为1号点与4号点连线的方向角
(Y1,Z1),(P-,165),(P+,15),(Y4,Z4) | Y1,Z1为1号点坐标，图示Y1为负 165°为1号点与2号点连线的方向角 15°为3号点与4号点连线的方向角
(Y1,Z1),(Y2,Z2),(P-,15),(P+,165) | Y1,Z1为1号点坐标，图示Y1为负 15°为2号点与3号点连线的方向角 165°为1号点与4号点连线的方向角
(Y1,Z1),(Y2,Z2), (Y3,Z3), (Y4,Z4) | Y1,Z1为1号点坐标


4.3.4. 附体

4.3.4. 附体

舵、首楼、尾楼、舱口围板、艏侧推孔等可以做成附体，以参与稳性计算

命令 | 注释 | 对应操作面板
APPENDAGE Name THR SO1 +SO2 -SO3 … | SO1、SO2、SO3体布尔组合构成附体，可以是（几何体、主船体、附体、单元体、舱室） + - * 表示体之间的并、差、交 布尔运算，运算符与图元名称之间不能有空格 |
例： APPENDAGE THR B1 +B2 +B3 | 表示B1与B2、B3求并得到一个附体


4.4. 编辑

4.4. 编辑


4.4.1. 删除

4.4.1. 删除

适用对象：所有图元

命令 | 注释 | 对应操作面板
DELETE name | name是删除点的名字，如果该图元被其他图元引用，这显示无法删除。 |
例： DELETE p4 | 删除几何点p4


4.4.2. 镜像

4.4.2. 镜像

适用对象：所有图元

命令 | 注释 | 对应操作面板
MIRROR SOURCE name | 生镜像点名字同源点，以“_M”结尾 name是源点的名字 镜像以船舯为对称面XOZ。 |
例： MIRROR SOURCE P1 | 创建与几何点p1相对应的镜像几何点。
例： MIRROR SOURCE C1 | 生成镜像线C1_M，其源线是C1
例： MIRROR SOURCE A1 | 生成镜像面A1_M，其源面是A1


4.4.3. 修剪

4.4.3. 修剪

适用对象：线、面

命令 | 注释 | 对应操作面板
TRIM SOURCE name BY P1 SAVEP P2 | name是被修剪线（面）的名字 p1是分割点（面） P2是保留部分所在的点，被保留的是距离该点最近的线（面） |
例： TRIM SOURCE C1 BY (-126.9137,-66.7175,60.1963) SAVEP (-50.7923,37.4654,88.2577) | 源曲线C1被剪切，保留部分是：点(-50.7923,37.4654,88.2577) 位于分割点(-126.9137,-66.7175,60.1963)的一侧。
例： TRIM SOURCE A10 BY A1 SAVEP (-59 -103 94) | 源面A10被A1剪切 保留的部分是：点(-59 -103 94)所在的一侧。 |
例： TRIM B1 BY A1 SAVEP (45, 129,-254) | 体B1被剪切，保留部分是点(45, 129,-254)位于分割面A1一侧。 |


4.4.4. 复制

4.4.4. 复制

适用对象：点、线

命令 | 注释 | 对应操作面板
COPY SOURCE p1 OFFSET (x,y,z) | P1源点的名字 (x,y,z) 各方向的偏移向量 |
例： COPY SOURCE P1 OFFSET (30,30,30) | 通过平移点p1来构造点p2的 平移量为(30,30,30)
例： COPY SOURCE C1 OFFSET (30,30,30) | 由C1经过平移（30,30,30）来得到的。实质是原来曲线上的点坐标值加上（30,30,30）来得到的


4.4.5. 拼接

4.4.5. 拼接

适用对象：线、面

命令 | 注释 | 对应操作面板
JOIN name SOURCE name1, name2…. | name1、name2 是待拼接的线（面）名字。 |
例： JOIN C3 SOURCE C1,C2 | 生成一条新的曲线C3，它是由曲线C1和C2拼接而成。并且保留C1和C2。 注：被拼接的两曲线必须有重合端点。
例： JOIN A3 SOURCE A1,A2 | 构造拼接面A3，它是由面A1和A2拼接而成的。 |


4.4.6. 求交

4.4.6. 求交

适用对象：面

命令 | 注释 | 对应操作面板
INTERSECT name BETWEEN A1,A2 | A1,A2是求交面的名字。 注：A1A2面必须相交 |
例： INTERSECT C BETWEEN A1,A3 | 获取曲面A1和A3的交线C


4.5. 分析(船舶稳性

4.5. 分析à船舶稳性

工具栏点击“分析”大图标，进入分析模块，创建计算模型、并执行计算

创建：操作面板“创建/船舶稳性”，对象面板出现相应节点，如下 | 计算：操作面板“计算/船舶稳性”，如下

计算假定如下：

（1）船体型线左右舷对称（双体船指左右片体对于船体中心线对称，不是片体自身对称）

（2）舱壁甲板边线认定左右舷对称

（3）进水点、浸水点左右舷不对称（应分别填写），进水点自动视为浸水点


4.5.1. 静水力

4.5.1. 静水力

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.5.1.1. 计算参数（基本信息）

4.5.1.1. 计算参数（基本信息）

稳性曲线横倾角计算间隔：默认2度

横倾角计算间隔角度范围：一般应大于最大稳性力臂对应的横倾角，当计算横倾角大于该值后，计算间隔将默认为5度；

计算吃水列表：双击可弹出编辑窗口，一般不要包含基平面吃水

X坐标类型：决定绑金曲线的X位置

静水力计算纵倾列表：允许用户输入多个纵倾，默认为0（无纵倾），纵倾值为首尾吃水差


4.5.1.2. 计算参数（船壳）

4.5.1.2. 计算参数（船壳）

船壳：包括主船体和附体（如舵、艏侧推孔等），其中艏侧推孔这类扣除项目的船壳系数应为负值

激活当前行时（点击），主窗口中高亮显示相应的船壳图元


4.5.1.3. 进水点（船型特征点）

4.5.1.3. 进水点（船型特征点）

进水点：左舷和右舷要分别填写

【右键菜单】

删除行：删除选中的多行或当前行

插入行：在当前行位置插入一行

上移行：将当前行上移一行

下移行：将当前行下移一行

修改位置ID：后续其他表格如用到了该ID，将自动同步更改


4.5.1.4. 出水入水点（船型特征点）

4.5.1.4. 出水入水点（船型特征点）

出水入水点：出水点可不填

【右键菜单】

删除行：删除选中的多行或当前行

插入行：在当前行位置插入一行

上移行：将当前行上移一行

下移行：将当前行下移一行

修改位置ID：后续其他表格如用到了该ID，将自动同步更改


4.5.1.5. 船体标尺（主菜单“船舶”->“船体标尺”）

4.5.1.5. 船体标尺（主菜单“船舶”->“船体标尺”）

静水力计算新增了输出型值表的功能，而型值表的输出间距是根据用户定义的船体型线标尺（站位、水线、纵剖线）来确定的。

船体型线标尺填写，主菜单“船舶”->“船体标尺”，如未填写则按默认值输出。


4.5.2. 舱容

4.5.2. 舱容

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.5.2.1. 基本信息

4.5.2.1. 基本信息

舱容曲线计算步长：在舱容曲线计算时，从最低水线开始，按此步长增量计算不同深度处的舱容参数。


4.5.2.2. 舱室

4.5.2.2. 舱室

关联进水点：下拉选择，用于完整稳性和破损稳性计算

默认密度：该舱室默认情况下装载的物品（固体或液体）的密度；如实际装载物品密度与之不同，可在具体工况的“装载子项”中指明其“密度”（详见4.5.3（3））

修改位置ID：后续其他表格如用到了该ID，将自动同步更改

【右键菜单】

初始化：将所有已经创建的舱室图元作为舱室加入该表中

删除行：删除选中的多行或当前行

插入行：在当前行位置插入一行

上移行：将当前行上移一行

下移行：将当前行下移一行

【主窗口】

当前行变化时，主窗口高亮显示当前行所关联的舱室图元


4.5.3. 完整稳性

4.5.3. 完整稳性

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.5.3.1. 基本信息

4.5.3.1. 基本信息

计算依据：选择计算所依据的法规（含年份）。

船舶类型：不用于稳性计算，用于控制船型相关计算参数是否可用，以及报告输出（标明校核船型）

包含“挖泥船”时，“正常作业许用极限静倾角”可见

包含“挖泥船”时，“正常作业许用极限静倾角”、“设有泥舱”可见

侧投影计算纵剖面列表：双击可弹出编辑窗口，用于计算主甲板与水线面之间侧向受风面积，一般应包括中纵剖面、尾轴中心面等侧向投影面积的特征控制面，双体船一定要包含片体中纵剖面。

实船试验确定回航极限静倾角：高速船的回航极限横倾角如果采用实船试验确定，则勾选，此时程序不再对回航静倾角进行校核衡准。


4.5.3.2. 空船重量

4.5.3.2. 空船重量

重心X、尾端X、首端X：必填，可填绝对坐标或肋位/站位坐标

类型：按下拉菜单选择

【右键菜单】

删除行：删除选中的多行或当前行

插入行：在当前行位置插入一行

上移行：将当前行上移一行

下移行：将当前行下移一行


4.5.3.3. 装载项

4.5.3.3. 装载项

每个“装载项”包含多个“装载子项”。

修改装载项ID：后续其他表格如用到了该ID（如“计算工况”），将自动同步更改

右键菜单：删除行、插入行、上移行、下移行。

“装载子项”分为装载重量、自由液面、乘客集舷、散货滑移四类

【装载重量及关联自由液面】

关联舱室：可下拉选择“舱室”数据表中的舱室项
如不为空，则“重量”与“装载比率”二选一，同时存在数据时“重量”优先，“密度”必填
如为空，则需要填入“重量”、“重心位置”和首尾端参数，X坐标可填绝对坐标或肋位/站位坐标

重量类型：按下拉菜单选择，用于重量类型的统计（计算中用到，并输出到报告中）

其中99表示不计重量，仅计入自由液面

舱室类型：1-直通外水，适用于活鱼舱等直接与舷外连通的液舱；

2-内液外溢，适用于挖泥船的运输泥浆舱，在计算稳性时会考虑其横倾后内部液货溢出。

自由液面计入方式：

“实际值”指根据舱内液体的体积自动计算自由液面；

“最大值”指取舱容计算中最大的自由液面；

“50%装载”指假定舱内液体装载比例为0.5时的自由液面；

“不计”指不计入自由液面，当重量类型为“99-不计”时，不能取该值

对于旋转式起重船：（吊臂垂直于船长方向时，对应作业状态）

起重机实际重心XYZ

吊臂假定横向伸出舷外处于最大横倾力矩状态

吊钩假定位于位于最高点

起吊货物假定位于吊钩悬挂点

对于旋转式起重船：（吊臂平行于船长方向时）

起重机应作为重量项计入，其重心XY取为基座的XY，重心Z取起重机整体最大可能的Z（可活动部件都处于最高点时），X方向分布范围取基座范围；

起吊货物也应作为重量项计入，其重心XY取为起重机基座的XY，重心Z取为起重机吊绳在吊臂上的悬挂点Z，并做如下转换（G1和G2的X方向分布范围可指定为一个较小的区间，G2为负值）

对于抓斗式挖泥船：（抓斗垂直于船长方向时，对应作业状态）

抓斗假定位于最大横倾力矩状态，抓斗位于最高位置

抓斗应作为重量项计入，其重心XY取为基座的XY，重心Z取抓斗整体最大可能的Z（可活动部件都处于最高点时），X方向分布范围取基座范围；

被抓物也应作为重量项计入，其重心XY取为抓斗基座的XY，重心Z取为抓斗可能的最高Z

对于扒杆式起重船：（固定吊臂式起重船）

起吊货物假定位于吊钩悬挂点

吊臂及起吊货物应通过力学分析，等效变换为扒杆基座点垂直向下的重力项G1（正值，单位t，X方向分布范围取基座范围）和扒杆拉索在船上连接点垂直向上的重力项G2（负值，单位t，X方向分布范围取连接点范围）

【非关联自由液面】

按IMO推荐的简易方法计算自由液面

【乘客集舷】

横向移动力矩：按法规的乘客布置要求（如内法规2016修改通报8.3.2.3、8.3.2.7），由用户通过其他方式计算得到并在此输入（提交送审时，需同时提交该数字的计算过程文档）
移动力矩=∑旅客人数×单人重量×移动距离

垂向移动力矩：按法规的乘客布置要求（如内法规2016修改通报8.3.2.3、8.3.2.7），由用户通过其他方式计算得到并在此输入（提交送审时，需同时提交该数字的计算过程文档）
移动力矩=∑旅客人数×单人重量×移动距离

【散货滑移】

散货楔形部分重量：由用户根据法规要求计算（如内法规2011-8.3.3），对于规则的货舱可按本软件提供的工具计算（工具栏->散货堆装计算 [image] ）


4.5.3.4. 受风项

4.5.3.4. 受风项

侧投影面积：对于非满实物体是指外轮廓投影面积

活动受风项ID：不能与“固定受风项ID”同名

满实系数：数值<1时，认为该项是“非满实受风项”
若“基本信息”中勾选了“非满实受风面积按满实取”则该项在计算时忽略不计

修改ID：后续其他表格如用到了该ID，将自动同步更改


4.5.3.5. 完整工况

4.5.3.5. 完整工况

船舶类型：根据基本信息中选定的“计算依据”（法规）而变
如果计算特定航线江海直达船，需要在基本信息中先选相应法规。

船舶子类：101对应船舶类型1-xxx；201对应2-xxx；其他类推

101-静倾受限客船，是指《内法规2015》所指的“第5类客船”，以及《内法规2016》所指“旅游船、游览船、客渡船、车客渡船”等

102-漓江游览船，《内法规2019》新增

301-浮油回收船，《内法规2011》~《内法规2019》均支持

衡准因素：“4-甲板货”，特定航线江海直达船装载甲板货时需要勾选

核算状态：“5-浸水”，用于核算特定航线江海直达集装箱船的浸水工况

拖索急牵、消防炮喷射、舷边起升、绞车横移、下桩定位、舷边排泥、不对称排泥等数据表，仅针对特定船型，可以为空

拖索急牵：对应拖船的“航行状态”而不是“作业状态”

挖泥船：
未设泥舱带有挖泥设备的挖泥船，对应“挖泥作业”；
专门运送泥沙的船（含泥驳和自航运泥船），对应“排泥作业”；
设有泥舱带有挖泥设备的挖泥船，对应“挖泥作业”或“排泥作业”，两种状态应分别计算，并在“备注”栏中标明

起重趸船：一般要计算如下工况
起吊作业，填写“舷边起升”，此时吊臂垂直于船长方向、吊臂最长，吊钩位于位于最高点，吊物位于吊钩处；
避风状态，起重机收起、无起吊物；
停泊（航行）状态，吊臂平行于船长，吊钩位于位于最高点，吊物位于吊钩处


4.5.4. 许用重心高度

4.5.4. 许用重心高度

双击对象面板的节点弹出编辑窗口，计算模型数据与“完整稳性”相同，所有数据为只读


4.5.5. 破损稳性

4.5.5. 破损稳性

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.5.5.1. 基本信息

4.5.5.1. 基本信息

与完整稳性基本相同


4.5.5.2. 浸没点/浸水点（船型特征点）

4.5.5.2. 浸没点/浸水点（船型特征点）

系指非水密开口（包括空气管、门槛、围板等）的下缘

已定义为进水点的点不必再次定义（进水点也默认为浸没点）

左右舷各不同舱室的浸水点分别填写

沿船长方向的开口一般应按首端、尾端、中点（如为直线段可省略中点）三个点填写

X：可填绝对坐标、肋位坐标或站位坐标

关联舱室：必填，一个浸没点可关联多个舱室，当舱室破损时，该浸没点在计算时不计入


4.5.5.3. 舱壁甲板边线

4.5.5.3. 舱壁甲板边线

X：可填绝对坐标、肋位坐标或站位坐标

左右舷可只填一舷（认为主船体型线对称）


4.5.5.4. 破损工况

4.5.5.4. 破损工况


4.5.6. 倾斜试验

4.5.6. 倾斜试验

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.5.6.1. 基本信息

4.5.6.1. 基本信息


4.5.6.2. 试验初始状态

4.5.6.2. 试验初始状态

（1）试验时吃水

相对船中平板龙骨平面型吃水：根据左右舷吃水读数，按法规要求从水尺标尺位置推算到艉垂线、舯垂线、艏垂线的型吃水（如有设计纵倾时，该值从倾斜龙骨平面量起）

（2）多余重量

各参数填写参照“完整稳性->装载项->装载重量”

（3）不足重量

（4）需重定位重量

（5）自由液面

各参数填写参照“完整稳性->装载项->自由液面”


4.5.6.3. 横倾测量读数

4.5.6.3. 横倾测量读数

（1）试验移动重量

（2）试验设备

（3）试验工况

（4）横倾读数

平均读数：对于两端U形管，含左右2个读数，逗号分隔；其他情况只有1个读数

第i次读数：

对于摆线，含左、右2个读数，逗号分隔，见上图

对于两端U形管，含左上、左下、右上、右下4个读数，逗号分隔；

对于一端U形管，含上、下2个读数，逗号分隔；

对于角度仪，含左、右2个读数，逗号分隔；


4.6. 分析(发证计算

4.6. 分析à发证计算

工具栏点击“分析”大图标，进入分析模块，创建计算模型、并执行计算

创建：操作面板“创建/发证计算”，对象面板出现相应节点，如下 | 计算：操作面板“计算/发证计算”，如下


4.6.1. 吨位计算

4.6.1. 吨位计算

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.6.1.1. 基本信息

4.6.1.1. 基本信息


4.6.1.2. V1容积

4.6.1.2. V1容积

按不同计算条件量计

0-按三维模型计算：选择用户创建的主船体（主体或附体）

1-已采用其他方式量计：直接输入量计的结果，V11+V12，V13

2-按辛氏第一法则量计：按法规要求输入计算数据

3-无型线图和邦氏曲线等资料的现有船舶：按法规要求输入计算参数

4-船长30m一下且无资料的船舶：按法规要求输入计算参数


4.6.1.3. V2容积

4.6.1.3. V2容积

可选择四种方法统计（四种方法可同时用或单独用）

1-三维模型计算：用户指定所创建的“舱室”

2-辛氏法计算：按法规要求填写等分点数据

3-长宽高计算：输入长、宽、高参数

4-几何法量计：输入采用几何方法量计得到的容积值


4.6.1.4. V3容积

4.6.1.4. V3容积

按类型填写计算参数

1-有顶盖/顶篷

2-无顶盖/顶篷


4.6.1.5. V4容积

4.6.1.5. V4容积

按三类处所填写（可同时存在）

1-一般处所：分为8个子类，1-有顶盖, 2-无顶盖无围板, 3-无顶盖货舱口, 4-非集装箱半舱船舱口, 5-仅周围有围板, 6-仅横向有围板, 7-浮箱甲板, 8-仅两侧有围板

2-无顶盖滚装处所

3-集装箱处所


4.6.1.6. V-容积（不计入的容积）

4.6.1.6. V-容积（不计入的容积）


4.6.2. EEDI计算

4.6.2. EEDI计算

双击对象面板的节点弹出编辑窗口，输入计算模型数据


4.6.2.1. 基本信息

4.6.2.1. 基本信息


4.6.2.2. 主机辅机能效参数

4.6.2.2. 主机辅机能效参数


4.6.2.3. 螺旋桨、轴带马达、轴带发电机能效参数

4.6.2.3. 螺旋桨、轴带马达、轴带发电机能效参数


4.7. 结果

4.7. 结果

工具栏点击“结果”大图标，进入结果模块，读入计算结果、查看计算结果、并输出报告

读入：操作面板“读入/XXXX”，对象面板出现相应节点，如下 | 输出：操作面板“输出/ XXXX”，如下
 | 可选择输出“PDF”或“RTF”格式的报告 RTF格式仅对“标准版”适用

双击对象面板中的相应节点，可查看计算结果


5. 特殊船型建模

5. 特殊船型建模


5.1. 艉封板

5.1. 艉封板

采用双向投影线

（1）第1投影面XZ：p11，p22

（2）第2投影面YZ：p21，0/，p22，p23，p24，/-，p25

（3）第1投影面的Z坐标（两个投影面的公共坐标）范围应包含第2投影面的所有节点：即

Z (p11) ≤Z(p21~p25)，Z (p12) ≥Z(p21~p25)


5.2. 首侧推孔

5.2. 首侧推孔

!辅助圆柱体

CYLINDERSOLID CYLIN

CENTER (95 8 2) (95 -8 2)

R 1 1

!侧推孔体

APPENDAGE SideThrustHole

THR Hull_1 *CYLIN

辅助圆柱体

侧推孔体


5.3. 带凸形甲板的油/化船

5.3. 带凸形甲板的油/化船


5.3.1. 方案一

5.3.1. 方案一

思路：外壳与内壳之间形成一个计算体，内壳与凸形甲板一个计算体

（1）黑色、粉色、绿色分别做线/面

（2）黑色面与粉色面围成主船体Hull_1

（3）粉色面与绿色面围成主船体Hull_2

（4）创建舷舱时指定Hull_1

（5）创建货舱时指定Hull_2


5.3.2. 方案二

5.3.2. 方案二

思路：外壳与凸形甲板形成一个计算体；舱室不从主船体切割得到，而是直接采用几何面围成的几何体

（1）黑色、粉色、绿色分别做线/面

（2）黑色面与绿色面围成主船体Hull_1

（3）创建舷舱时用黑色面与粉色面以及船底纵桁/水密横舱壁/平台等通过“几何体à围拢”生成几何体，然后通过“舱室à体组合”指定为舱室

（4）创建货舱时用粉色面与绿色面以及船底纵桁/水密横舱壁/平台等通过“几何体à围拢”生成几何体，然后通过“舱室à体组合”指定为舱室


5.3.3. 方案三

5.3.3. 方案三

思路：外壳与虚拟的平甲板（不含凸形部分）形成一个计算体；舱室不从主船体切割得到，而是直接采用几何面围成的几何体

（1）黑色、粉色、绿色分别做线/面

（2）黑色面与红色面围成主船体Hull_1

（3）创建舷舱时用黑色面与粉色面以及船底纵桁/水密横舱壁/平台等通过“几何体à围拢”生成几何体，然后通过“舱室à体组合”指定为舱室

（4）创建货舱时用粉色面与绿色面以及船底纵桁/水密横舱壁/平台等通过“几何体à围拢”生成几何体，然后通过“舱室à体组合”指定为舱室


5.4. 双体船

5.4. 双体船


5.4.1. 方案一

5.4.1. 方案一

思路：片体与半个连接桥形成一个计算体（组合片体），组合片体镜像得到另一半

（1）黑色、粉色、绿色/紫色、蓝色分别做线/面

（2）黑色、粉色、绿色/紫色、蓝色围成主船体Hull_1

（3）镜像主船体Hull_1得到主船体Hull_2


5.4.2. 方案二

5.4.2. 方案二

思路：片体形成一个计算体，镜像后得到另一个片体，连接桥单独形成一个计算体（附体）

（1）黑色/红色、粉色、绿色/紫色分别做线/面

（2）黑色/红色、绿色围成主船体Hull_1（片体）

（3）镜像主船体Hull_1得到主船体Hull_2（片体）

（4）红色、粉色、紫色围成主船体Hull_3（连接桥）

另：也可将连接桥也分成左右两部分来做；如连接桥部分没有水密箱形结构，可不做，或只做甲板（甲板的上下表面按两个面来做）


6. 版本更新说明

6. 版本更新说明


6.1. V2019.20.0801

6.1. V2019.20.0801

2020年08月05日发布

调整如下功能：

（1） 模型数据文件格式更新，完整稳性模块中，“装载项”与舱室关联的自由液面，从“自由液面”表格转移到“装载重量”，新格式文件在旧软件中使用时，如果存在于舱室关联的自由液面，会出现计算错误。

（2） 三维体的三角网格：显示颜色，正面修改为灰色，反面修改为红色；

（3） 三维体的三角网格：图形显示与计算输出的网格生成算法调整一致；

（4） 倾斜试验模块，增加对横倾设备参数的数据检查；

修正如下bug：

（5） 三维网格曲面的属性面板不正常，带圆弧的网格曲面创建出错；

（6） 完整稳性参数填写时，“链斗挖泥船”没有“排泥力矩”，多了“下桩力矩”

（7） 完整稳性参数填写时，“装载项·装载重量”单元格智能关联异常

（8） 完整稳性计算时，选择2019版内法规，“乘客集舷”、“自由液面”报错；

（9） 完整稳性计算时，选择2019版内法规，增加了完整工况中的船型为“趸船”时的数据检查；

（10） 破损稳性计算时，同一个浸没点关联多个舱室不正常；

（11） 吨位计算，报告输出指向不正常，相关参数的有效位数输出不符合需要；

（12） 修订了安装文件夹下算例“算例-100m双尾球首散货船.csx”首尾升高甲板的建模方式。


6.2. V2019.20.0601

6.2. V2019.20.0601

2020年05月29日发布

（1） 静水力：增加对纵倾支持，允许按用户需要计算多个纵倾状态。

（2） 完整稳性衡准：新增“内法规2019”衡准选项；

（3） 完整稳性船舶子类：新增“102-漓江游览船”和“301-浮油回收船”；

（4） 完整稳性装载重量：新增“舱室类型”列，选项包括1-直通外水（适用于活鱼舱等直接与舷外水连同的液舱，当重量项关联舱室时可选），2-内液外溢（适用于挖泥船的运输泥舱等内部液货可能溢出的液舱，当重量项关联舱室时可选）；

（5） 破损稳性：破损舱室水线面增加对渗透率的考虑。

（6） 浮态平衡计算：完善迭代方法，解决一些特殊船型浮态迭代难以收敛的问题。

（7） 倾斜试验：试验工况增加右键菜单“初始化”；重量项、自由液面关联舱室后默认密度取0，表示自动关联舱室的默认密度。

（8） 吨位计算：半舱货船的净吨位系数公式修正。


6.3. V2019.20.0101

6.3. V2019.20.0101

2019年12月30日发布

（1） 表格输入：枚举下拉单元格的显示，由整数修改为与下拉项一致。

（2） 修正舱容数据编辑bug：初次进入时船壳高亮；部分舱室行无法删除。

（3） 修正破损组合编辑bug：复制和粘贴单元格时，舱室名称自动增加了不应有的后缀；

（4） 倾斜试验：计算时增加横倾记录数据检查；

（5） 性能计算bug：基本参数中的计算吃水单元格，双击编辑返回后单元格无文字显示；

（6） 吨位计算；计算时增加数据检查；


6.4. V6.19.1201

6.4. V6.19.1201

2019年12月10日发布

（1） 图形交互功能完善：

a) 解决了“三角”功能激活时在界面上选择面图元不能高亮的问题；

b) 解决了部分用户的电脑使用“三角”功能出错的问题；

c) 解决了面或体隐藏时仍然能够捕捉到网格的问题；

d) 解决了在属性面板有时修改线不成功的问题。

（2） 修正了分析计算的一些bug：

a) 解决舱室等下拉项中包含“-”字符时，无法正确选择的问题；

b) 解决完整工况不能删除的问题；

c) 解决倾斜试验计算存在关联舱室的自由液面修正时输出报告出错的问题；

d) 倾斜试验计算工况重量项数据为空时计算报错的问题；

（3） 报告输出修改：

a) 静水力报告中去掉“湿表面面积”，原“方形系数”增加“（水线船长）”描述，增加“方形系数(规范船长)”。

b) 完整稳性报告，增加“方形系数(水线船长/规范船长)”。


6.5. V6.19.1001

6.5. V6.19.1001

2019年9月30日发布

（1） 修正了分析计算的一些bug

a) 打开某些旧版数据文件时， “静水力”等数据无法编辑；

b) 修改了数据表格中下拉项的显示模式，修正了某些情况下选择项与单元格数值不对应问题

c) 输出报告中，完善了规范法规的名称和版本表达方式

d) 完整稳性输出报告，修正了“乘客集舷倾侧力矩”表格的输出

（2） 修复了创建曲面时出现的错误。


6.6. V6.19.0801

6.6. V6.19.0801

2019年8月1日发布

（1） 修正了散货堆装计算时楔形体的重心高计算；

（2） 修正了特定航线船舶的许用重心高的计算；

（3） 增加了江海直达船舶不计算散货衡准的检查。


6.7. V6.19.0701

6.7. V6.19.0701

2019年7月1日发布

（4） 三维模型新增对外接口

a) 新增型值表导入建模，以及型值表输出（静水力计算时）；

b) 新增IGES导入和导出建模；

c) 新增DXF导入建模和后处理；

（5） 稳性衡准新增船型和规范

a) 新增对《特定航线江海直达船舶法定检验技术规则》2018支持；

b) 稳性衡准新增对《内河船舶法定检验技术规则》2018修改通报支持；

（6） 稳性模块新增与总纵强度模块接口

a) 完整稳性计算时输出船体梁静水弯矩剪力数据，可直接在总纵强度模块中导入

（7） 新增吨位计算模块，配套从2011版本开始的各版内法规，可通过指定三维模型计算各容积

（8） 新增EEDI计算模块，配套内河绿色船舶规范2018


6.8. V5.18.0426

6.8. V5.18.0426

2018年4月27日发布

进行下述修改完善：

（9） 修复了曲线的“联动”功能

（10） 修改了椭圆弧和抛物线创建梁拱选错甲板边点时的提示信息

（11） 修复了用“单向投影”创建点后无法更新的问题

（12） 在站位初始化定义时自动增加“-1”站和 "n+1"站

（13） 完整稳性计算参数填写时检查填写，当所填写项的ID未填时给出提示


6.9. V5.18.0326

6.9. V5.18.0326

2018年3月26日发布

进行下述修改完善：

（1） 优化舱室生成算法

（2） 倾斜试验中试验水域密度修正


6.10. V5.18.0201

6.10. V5.18.0201

2018年2月1日发布

对下述异常进行修改完善：

（1） 镜像多个图元时仅指定一个图元名称结果异常

（2） 双向投影曲线创建异常

（3） 散货堆装计算结果增加楔形部分重量输出

（4） 部分工况浮态平衡计算不收敛，调整最大迭代计算次数

（5） 完整稳性计算中当最小倾覆力臂找不到时输出结果从“非数字”修改为“负无穷”

（6） 总纵强度输出报告pdf无边框模式没有水印，优化精简模式的输出内容

（7） 更新用户手册，增加舱室案例

新增以下功能：

（8） 稳性分析界面中点击舱室、关联舱室、破损舱室时，图形窗口高亮显示对应图元


6.11. V5.18.0101

6.11. V5.18.0101

2018年1月4日发布

对下述异常进行修改完善：

（1） 梁拱线DP点Y坐标为负时无法创建

（2） 创建曲线时“错误信息提示”错位

（3） 静水力计算中排水量接近0时初稳性高等计算异常

（4） 静水力计算中存在需要扣除的附体时绑金曲线结果异常

（5） 稳性计算中许用极限静倾角异常

（6） 稳性计算中双体/多体船中横剖面系数、菱形系数异常

（7） 结果图表显示时死循环

（8） 倾斜试验报告中空船重量和重心在两个地方输出结果不完全一致

新增以下功能：

（9） 快捷工具栏增加“创建”按钮，与“镜像”等功能并列

（10） 创建网格曲面时可提示重复曲线的序号

（11） 稳性分析中“出水点”允许不填

（12） 输出报告允许选择正常、表格无边框、精简无详情三种模式


6.12. V5.17.1215

6.12. V5.17.1215

2017年12月18日发布

对下述异常进行修改完善：

（1） 命令流设置肋位表时，点击快捷按钮“F”不显示肋位标尺

（2） 稳性计算结果中进水点与初始横倾方向不一致

（3） XYZ曲线节点坐标填写窗口中，输入折角标志“-”时提示错误

（4） 平面曲线中X平面位置，使用$0.75站位坐标时提示错误

（5） XYZ创建多个点时，仅创建了一个，后续被忽略

（6） 引用曲线上与某平面的交点，有时找不到点

（7） 创建点的命令POINT，支持同时创建多个点

（8） 同时镜像多个面和体，其中一些面和体对应的命令有误

（9） 完整稳性和许用重心高度计算，乘客集舷有时无结果

（10） 计算报告页面精简，并调整为紧凑型排版

（11） 倾斜试验报告，重量重心在两个部分结果显示稍有差异

新增以下功能：

（12） 稳性计算中用到的船壳图形对象检查，不存在或已删除时输出提示

（13） 稳性计算中用到的舱室图形对象检查，不存在或已删除时输出提示

（14） 稳性计算中船体/舱室计算网格与船壳/舱容计算数据表的一致型检查


6.13. V5.17.1101

6.13. V5.17.1101

2017年11月3日发布

对下述异常进行修改完善：

（1） 更正舱室更新后变为舱室单元；

（2） 进一步完善稳性计算的数据检查功能；

（3） 乘客集舷计算中相当人数算法；

（4） 散装水泥船进水角；

（5） 完整稳性报告lm衡准数异常；

（6） 倾斜试验计算的不正常警告提示；

新增以下功能：

（7） 散货堆装计算，重心、堆高、受风面积与中心


6.14. V5.17.1001

6.14. V5.17.1001

2017年9月29日发布

对下述异常进行修改完善：

（1） 梁拱线（圆弧和抛物线）增加支持梁拱高度为0，退化为直线

（2） 完整稳性计算时新增对重量项原点与船体标尺原点的匹配性检查

（3） 完整稳性计算数据表的ID项自动去掉首尾空格和制表符

（4） 完整稳性计算报告，受风面积输出完善

（5） 完整稳性计算报告，起重船绞车横移数据项未输出

（6） 其他已知问题


6.15. V5.17.0901

6.15. V5.17.0901

2017年8月29日发布

对下述异常进行修改完善：

（7） 点、线的复制与镜像后可再次编辑

（8） “进水点”和“浸水点”修改为区分左右舷，“进水点”自动视为“浸水点”

（9） “立体视图”修改为船尾在左，“仰望视图”修改为船尾在左

（10） 双体船等特殊船型复原力臂最大值计算异常

（11） 计算报告封面显示“计算签名”，正文页眉增加“计算签名”显示

新增以下功能：

（12） 面、体、主体、舱室、单元、附体的复制功能

（13） 舱室增加“关联进水点”属性，“浸水点”增加“关联舱室”属性，破损舱室的关联进水点和浸水点在破损计算时自动过滤不计

（14） 静水力计算增加20站绑金曲线结果输出，对应文件*.Bonjean20，选择复制后能直接粘贴到总纵强度的绑金曲线表格中

（15） 完整稳性结果增加“进水点”至水面最小距离输出

（16） 破损稳性结果显示稳性力臂曲线图


6.16. V5.17.0801

6.16. V5.17.0801

2017年8月1日发布

对下述异常进行修改完善：

（1） 站位表不能插入0站

（2） 创建对象时重名错误没有提示

（3） 倾斜试验报告中“自由液面”数据表错位

（4） 属性面板中图元名称修改为只读

（5） 当前属性面板中图元序列控件或节点序列控件中进行修改时，属性面板不会自动跳转

新增以下功能：

（6） 曲线创建面板中使用工具栏“首端点”、“尾端点”等返回的曲线，高亮显示

（7） 旅客集中一舷情况下，完整稳性计算报告中提示需提交横倾力矩的详细计算附加报告；

（8） 主船体、舱室、单元体、附体等增加“体组合”方式，支持几何体、主船体、舱室、单元体、附体等所有体对象的布尔运算

（9） 几何（船壳）编辑功能与创建功能分离，并集中以工具栏方式体现

（10） 新增“分析”窗口中选中“舱室”时图形视图高亮显示


6.17. V5.17.0701

6.17. V5.17.0701

2017年7月4日发布

对下述异常进行修改完善：

（1） 圆弧梁拱线不显示节点，也无法引用节点

（2） 完整工况数据表中“装载项”下拉项被遮挡

（3） 部分完整稳性工况计算不收敛

（4） 部分舱室舱容曲线无法计算

（5） 液舱自由液面关联舱室时，“最大值”计入方式结果异常

（6） 弯扭组合强度计算中，当剖面号不是按顺序与船体梁段对应时，无法计算扭转

新增以下功能：

（7） 增加稳性数据模型逻辑检查功能，基本参数不能为空，船壳数据表不能为空

（8） 增加稳性书模型逻辑检查功能，关联舱室、装载项、受风项应存在


6.18. V5.17.0601

6.18. V5.17.0601

2017年6月1日发布

对下述异常进行修改完善：

（1） 双向投影不成功闪退，自动增大第1投影面减少投影线确保成功，支持节点坐标输出

（2） 现有数据模型曲线引用节点失败

（3） 图元更名后关联高级图元对应命令未更名

（4） 船体为组合体时不能创建舱室

（5） 图形对象显示优化——当图形本身不可见但通过树窗口选中时也会高亮

（6） “装载项”与“受风项”ID带有“-”字符时，完整工况无法填入

（7） 船体带有需扣除的附体（船壳系数<0）时排水体积与排水量结果异常

（8） 计算结果曲线图插值，直接显示真实值

（9） 计算结果中有正（负）无穷时无法显示和输出

新增以下功能：

（10） 网格曲面的单元格边数只能为3或4，其他情况不生成曲面片

（11） 破损计算增加“舱壁甲板位置”与“浸水点位置”显示

（12） 完整计算报告增加自定义“备注”信息输出，“工况”数据表增加“备注”列输出

（13） 根据吃水、横倾、纵倾查询排水量、横稳心等浮性参数


6.19. V5.17.0501

6.19. V5.17.0501

2017年5月1日发布

对下述异常（bug）情况进行修改完善：

（1） 主甲板以下受风面积（计算面不在中纵剖面时）

（2） 进水角对应的稳性力臂为负

（3） 新建并编辑“稳性计算/静水力”、“稳性计算/舱容”报错

（4） 舱容曲线计算报错“被约束为是唯一的”

（5） 倾斜试验试验设备组数限制调整为1~5，适应20m以下小船的需求

（6） 无进水点时无法计算

新增以下功能：

（7） 双向投影，将第1投影面设定为辅助面，第2投影面设定为主投影面

（8） 双向投影、圆弧、抛物线曲线增加节点显示，双向投影曲线的节点由第2投影面决定

（9） 新增“重建”功能，允许用户重建选定的图元或所有图元

（10） 新增“联动”控制功能，允许用户在新建、修改、重建图元时，是否自动更新关联的图元

（11） 在数据文档中保存点、线、面等各类图元的可见性控制状态，载入时自动恢复设定


6.20. V5.17.0401

6.20. V5.17.0401

2017年4月1日发布

对下述异常（bug）情况进行修改完善：

（1） 舱容曲线计算卡死

（2） 回航力臂为负时稳性衡准结果错误

（3） 回航静倾角无结果

（4） 完整稳性计算中计算工况详情中有不合格项但结论显示合格

新增以下功能：

（5） 重量项X方向重心与分布范围逻辑正确性检查

（6） 用户手册中“装载子项”详细说明，补充旋转式和扒杆式起重船重量项填写说明

（7） 船壳体、舱室体未变化时不重复生成计算网格


6.21. V5.17.0316

6.21. V5.17.0316

2017年3月16日发布

对下述异常（bug）情况进行修改完善：

（1） 稳性输出报告“船舶子类”输出

（2） 极限静倾角曲线结果异常

（3） 破损稳性计算结果异常

（4） 曲线循环引用造成更新相关曲线时死机

（5） 稳性曲线等图形输出优化，标尺和显示范围

（6） 优化载荷曲线、空船重量分布曲线计算和输出

新增以下功能：

（7） 增加稳性计算中数据项ID的检查，不能包含逗号等特殊分隔符

（8） 增加站位表的数据检查

（9） 静水力中增加稳性横截曲线计算和输出

（10） 完整稳性报告中增加载荷分布曲线数据表


6.22. V5.17.0301

6.22. V5.17.0301

2017年3月3日发布

对下述异常（bug）情况进行修改完善：

（1） 曲线图元的依赖项自动联动更新

（2） 曲线图元的引用节点标记显示不正确

（3） 倾斜试验数据表格中自由液面数据填写异常

（4） 稳性力臂曲线结果异常（计算倾角范围内个别倾角对应的稳性力臂无值）

（5） 稳性消失角结果异常（稳性力臂曲线与Y=0有交点，但消失角结果无值）

（6） 静水力、完整稳性和破损稳性中进水角、出水角、入水角、最大复原力臂结果异常

（7） 破损稳性对进水点不存在情况的支持

（8） 破损稳性个别大舱破损时浮态结果异常

（9） 舱容曲线坐标值为负时显示和输出报告异常

（10） 倾斜试验计算最小二乘法异常

（11） 完整稳性报告中自由液面、重量统计项（压载水、油水）

（12） 破损稳性报告中水面至舱壁甲板和浸水点的输出错误

新增和补充以下功能：

（13） 增加图元覆盖时的类型检查，不同类型不允许相互覆盖

（14） 增加ocm数据文件的缺失检查，图形显示异常

（15） 完善双体船的静水力（片体与全船分开输出）、完整稳性、破损稳性的计算和报告


6.23. V5.17.0208

6.23. V5.17.0208

2017年2月8日发布

对下述异常（bug）情况进行修改完善：

（1） 进水角计算结果异常

（2） 集舷静倾角计算结果异常

（3） 部分船型计算吃水过大时稳性计算不收敛异常

（4） 液舱默认密度与装载项密度同时设定时，修改为以装载项为准

（5） 消防船许用极限静倾角、喷射稳性结果异常

（6） 倾斜试验计算结果异常

（7） WINXP操作系统下报告输出异常

（8） 计算日期保存异常，报告中计算日期输出

（9） 完整稳性报告中集舷数据项输出异常

（10） 许用重心报告异常

新增如下功能：

（11） 新增命令regencommand，用于输出所有图元（未选定图元时）或选定图元的命令流

（12） 计算结果中根据三维模型计算所得水线船宽Bs限定为不大于用户在主要参数中指定的船宽B

（13） 静水力计算结果中船型系数（Cb、Cp、Cw等）的分母修改为水线船宽Bs和水线船长Lwl，并在计算报告中注明

（14） 稳性计算结果中增加“进水角”对应的“进水点位置”输出

（15） 稳性计算结果中，重量项的统计项增加X尾端和X首端输出

（16） 稳性计算结果增加曲线图显示：静水力曲线、进水角与极限静倾角曲线、邦金曲线、舱容曲线、稳性力臂曲线、载荷曲线（重量、浮力、剪力、弯矩等）、空船重量曲线、许用重心高度曲线

（17） 计算报告增加曲线图显示：静水力曲线、进水角与极限静倾角曲线、邦金曲线、舱容曲线、稳性力臂曲线、载荷曲线（重量、浮力、剪力、弯矩等）、空船重量曲线、许用重心高度曲线


6.24. V5.17.0101

6.24. V5.17.0101

2017年1月1日发布

作出如下修改完善：

（1） 保存文件：优化功能，将数据分离为两部分保存，用户数据文件csx和几何数据文件ocm;增加了备份文件csx.bak和ocm.bak

（2） 稳性模型：用户输入窗口，增加破损工况复制功能

（3） 稳性计算：破损工况下进水角计算错误，船型参数修改为以水线船长和水线船宽为分母

（4） 输出报告：静水力报告增加静水力曲线，破损报告bug修正


6.25. V5.16.1201

6.25. V5.16.1201

2016年12月1日发布

作出如下修改完善：

（1） 打开模型文件：增加图形自适应显示

（2） redo/undo：修正使用undo时报错的bug

（3） 图元名称：修正通过树节点更改图元名称后图元的命令定义未更名的bug，以及该图元关联图元的命令定义未更名的bug；修正未指定图元名称时图元的命令定义中未包含默认名称的bug

（4） 镜像：增加对“舱室”、“船体”等图元的支持；新增可指定镜像面位置（默认Y=0）

（5） 快捷工具“显示节点坐标”：修正平面和空间曲线更新后结果显示不正确的bug；增加对“点”图元的支持；增加对“圆弧、抛物线”等曲线图元的支持，显示首尾端点坐标

（6） 完整稳性/装载项：增加右键菜单，实现装载项的复制

（7） 完整稳性/计算工况：修正“船舶子类”界面数据与计算不对应的bug；增加右键菜单，实现工况项的复制

（8） 浮态平衡计算：完善计算算法，解决部分计算工况不收敛问题

（9） 完整稳性：精简输出报告，根据“船舶类型”、“船舶子类”、“衡准因素”等信息，隐藏无关的输出项，增加各衡准量的衡准数输出，更正自由液面数据输出错误。


6.26. V5.16.1111

6.26. V5.16.1111

2016年11月8日发布

支持《内河船舶法定检验技术规则》2016修改通报、《钢质内河船舶建造规范》2016。

包含如下计算功能：

（1） 静水力计算（含绑金曲线、进水角曲线、极限静倾角曲线）

（2） 舱容曲线计算

（3） 完整稳性计算

（4） 许用重心高度计算

（5） 倾斜试验计算

（6） 船体梁总纵弯曲强度计算

（7） 船体梁弯扭组合强度计算


7. FAQ 常见问题及处理方法

7. FAQ 常见问题及处理方法


Q1：打开以前创建的文件失败，怎么办？

Q1：打开以前创建的文件失败，怎么办？

A1：使用本程序前关闭其他程序，确保电脑有足够的可用内存。


Q2：构建模型所用时间比较长，如何可以提高效率？

Q2：构建模型所用时间比较长，如何可以提高效率？

A2：可以参看第3、4章，结合命令操作，会使操作变得更快速。


Q3：生成网格曲面有“破洞”怎么办？

Q3：生成网格曲面有“破洞”怎么办？

A3：有破洞说明在程序运算时判定曲线没有形成有效的四边形网格，或者网格存在二义性，此时可将需要生成的网格曲面再细分成多个小区域再试。

注：尤其要注意，最好不要把甲板边线、中纵剖线、甲板中心线等在全船长度范围内做成一根曲线，至少应分成首、（中）、尾几个区段来做，参见第3章。


Q4：构造的曲面形状不好，怎么提高光顺性？

Q4：构造的曲面形状不好，怎么提高光顺性？

A4：曲面片的边界不要超过4条，否则添加辅助线使5条以上边界变成4条（单向投影线的位置面坐标采用引用表达式，从而准确定位到指定点，例如C1/N=?或C1/C2）

尾封板的外轮廓很复杂，可以将其拆分成几个面来创建；或者先创建一个大的平端面，然后用边界线修剪；否则可能无法用于生成主船体

︾


Q5：构造的网格曲面失败，怎么办？

Q5：构造的网格曲面失败，怎么办？

A5：网格曲面片的边界线尽可能不要有太小的锐角，如下图


Q6：采用“参数化舱室单元体”组合生成“舱室”时，不成功怎么办？

Q6：采用“参数化舱室单元体”组合生成“舱室”时，不成功怎么办？

A6：当舱室单元体的端面重合时会存在这样的情况，可以调整舱室单元体的端面位置，将两个单元体的端面错开1mm即可


Q7：船体/舱室计算所得容积为负或随高度增加负增长？

Q7：船体/舱室计算所得容积为负或随高度增加负增长？

A7：构成船体/舱室的曲面，有重叠面（如下左图），或某个面的单元格边界线仅两条（如下右图）

正确做法（︾）去掉重叠部分

正确做法（︾）拆开成三/四条边


Q8：曲面单元为何形状不光顺？

Q8：曲面单元为何形状不光顺？

A8：曲面网格的边数，最好是3或4条，如果有5条边则程序会自动在两点之间连一条直线将5条边拆分成两个4条边，如下图；

正确做法（︾）增加辅助线，将五条边拆成四条边